Attribute “layout_anchorGravity“ already defined with incompatible format.

在整理一个老项目替换aar包的build过程中发现报了

Attribute "layout_anchorGravity" already defined with incompatible format.

这个问题问题
在这里插入图片描述进一步发现可能是design包的引用出了问题
使用gradlew命令输出工程依赖的信息

./gradlew dependencies  > dependence.txt

发现确实如此,项目中有23,27两个版本
在这里插入图片描述在这里插入图片描述最后在主工程里面强制规定死版本解决这个问题

configurations.all {
        resolutionStrategy.force 'com.android.support:design:27.1.1'
    }

类似的问题可以用同一个思路去解决

你可能感兴趣的