npm 安装yarn_NodeJS包管理器之Yarn

一、安装yarn

  首选必须先安装好NodeJS,之后可以去yarn官网下载mis安装程序安装。由于NodeJS自带了一个包管理器npm,所以安装yarn更简单的方法是直接使用npm install -g yarn即可。

  如果想要升级yarn,可以先从网上查询yarn最新版本号,一般yarn有新版本控制台会自动提示,如

npm 安装yarn_NodeJS包管理器之Yarn_第1张图片

   这时,只要使用指定版本号的命令即可升级。

  npm install yarn@1.19.2 -g

npm 安装yarn_NodeJS包管理器之Yarn_第2张图片

二、修改yarn全局包与缓存的安装位置

检查当前yarn的bin的位置:yarn global bin

检查当前yarn的全局安装位置:yarn global dir

检查当前yarn的全局缓存位置:yarn cache dir

修改当前yarn的全局安装位置:yarn config set global-folder "D:Softwareyarnglobal"

修改后如果用yarn安装的全局目录没有生效,重新打开cmd再用yarn安装即可。

相应修改yarn的缓存:yarn config set cache-folder "D:Softwareyarncache"

清除全局缓存:yarn cache clean

yarn默认带命令的安装包,生成的命令不像npm那样直接放到global(npm config get prefix)目录下,而是放到了global(yarn config get global-folder)下的.bin目录,也拷贝到了bin(yarn global bin)中一份,因此需要将上述两个目录之一添加到系统path中。

三、yarn基本命令

  yarn包管理器与npm类似:

npm 安装yarn_NodeJS包管理器之Yarn_第3张图片

安装包:yarn [global] add [package]@[version]

更新包:yarn upgrade [package | package@tag | package@version | @scope/]... [--ignore-engines] [--pattern]

删除包:yarn remove

列出所有包和它们的依赖:yarn list [--depth] [--pattern]

运行脚本:yarn run [script] []

你可能感兴趣的