android 群控 网络 adb,逍遥安卓模拟器群控源码

逍遥安卓模拟器群控源码

@懒鸟

.版本 2

.支持库 iext

.子程序 命令adb, 文本型, 公开

.参数 命令1, 文本型

.局部变量 执行文本, 文本型

.局部变量 执行头, 文本型

.局部变量 返回结果, 文本型

.局部变量 i, 整数型

.局部变量 真假, 逻辑型

' 暂停 ()

执行头 = 编辑框_模拟器地址.内容 + “ -s 127.0.0.1:”

真假 = 假

.计次循环首 (超级列表框1.取表项数 (), i)

.如果 (超级列表框1.取当前状态图片 (i - 1) = 1 且 超级列表框1.取标题 (i - 1, 4) = “在线”)

执行文本 = 执行头 + 超级列表框1.取标题 (i - 1, 2) + “ ” + 命令1

' 编辑框5.内容 = 系统_取DOS执行结果 (执行文本)

线程多参 (到整数 (&系统_取DOS执行结果), 执行文本)

' 启动线程 (&显示桌面, , )

.如果真 (真假 = 假)

线程多参 (到整数 (&显示桌面), 执行头 + 超级列表框1.取标题 (i - 1, 2), 超级列表框1.取标题 (i - 1, 1))

真假 = 真

.如果真结束

' 显示桌面 ()

' 系统_取DOS执行结果 (编辑框_模拟器地址.内容 + “ -s 127.0.0.1:” + 超级列表框1.取标题 (0, 2) + “ shell screencap -p /sdcard/” + 超级列表框1.取标题 (0, 1) + “.jpg”)

' 系统_取DOS执行结果 (执行头 + 超级列表框1.取标题 (i - 1, 2) + “ pull /sdcard/” + 超级列表框1.取标题 (i - 1, 1) + “.jpg D:\”)

' 图片框1.图片 = 读入文件 (“D:\” + 超级列表框1.取标题 (i - 1, 1) + “.jpg”)

.否则

' 执行文本 = 编辑框_模拟器地址.内容 + “ ” + 命令1

' 返回结果 = 系统_取DOS执行结果 (执行文本)

.如果结束

.计次循环尾 ()

返回 (返回结果)

android 群控 网络 adb,逍遥安卓模拟器群控源码_第1张图片

文件下载

解压密码:

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网⑤群:21414575)

你可能感兴趣的