开启Vue项目缺少node_models包的问题及解决

开启Vue项目缺少node_models包

运用Vue ui时出现的一些问题

1. 当我们通过Vue ui 导入新的vue项目时显示缺少node_models包问题

此文件夹缺少 ‘node_modules’。请安装依赖后再尝试导入。

错误页面如图:

开启Vue项目缺少node_models包的问题及解决_第1张图片

问题原因

错误原因是没有安装该项目所需要的依赖项(代码入库时是不需要保留依赖项的,因为依赖项只在项目编译打包或项目运行时使用。所以从git仓库或svn仓库拉下来的代码需要先安装依赖),执行命令安装后即可正常导入。 

解决办法一:

重新安装node_models

  • 1.进入到项目的根目录
  • 2.打开cmd命令窗口
  • 3.执行安装命令
cd my-project	# 进入到项目目录
npm install 	# 普通安装
npm install --registry https://registry.npm.taobao.org
#换源安装速度会比较快

这步很关键最好换源安装否则项目可能依旧不能启动

npm run dev# 项目启动成功

改方法的弊端每次新开启一个项目都需要重新安装node_models包很麻烦

vue项目依赖node_modules装不上去

从代码库里拉取代码,安装依赖特别卡,等待许久之后报了一大堆错,项目也启动不起来。后来在大佬的帮助下解决了,

可以试试先运行

npm install -g mirror-config-china

npm快速换源

npm install -g mirror-config-china

然后再重新 npm i 即可

npm i

以上为个人经验,希望能给大家一个参考,也希望大家多多支持脚本之家。

你可能感兴趣的