MindSpore 1.7自动安装 GPU篇

MindSpore 1.7推出一个方便的安装方式,自动安装,试着体验一下官网操作指南链接是:https://www.mindspore.cn/install我选择的是cuda 10.1+py3.7的版本
MindSpore 1.7自动安装 GPU篇_第1张图片

  1. 第一步 根据安装说明:在使用自动安装脚本之前,需要确保系统正确安装了NVIDIA GPU驱动。CUDA 10.1要求最低显卡驱动版本为418.39;CUDA 11.1要求最低显卡驱动版本为450.80.02。执行以下指令检查驱动版本。nvidia-smi
    MindSpore 1.7自动安装 GPU篇_第2张图片
    确认是418.39 真好合适2. 第二步下载安装脚本
    MindSpore 1.7自动安装 GPU篇_第3张图片
    在官网解释中,说的是支持1.6.0及以上的版本,但是当我选择1.6版本的时候,并没有写着自动安装,这个我也不确定1.6支不支持还是按照1.7的来获取安装脚本
    图片
  2. 执行脚本发现存在问题:MINDSPORE_VERSION=1.7.0 bash -i ./ubuntu-gpu-pip.shCUDA 11.1 minimum required driver version is 450.80.02,         but current nvidia driver version is 418.39, please upgrade your driver manually.
    图片
    我明明是cuda10.1, 为什么报11.1呢查看脚本发现脚本里面CUDA_VERSION=${CUDA_VERSION:-11.1} 设置的cuda是11.1, 需要手动改成10.1
    图片
  3. 再次执行脚本
    MindSpore 1.7自动安装 GPU篇_第4张图片
    中间有点长,只截部分下面显示安装成功
    MindSpore 1.7自动安装 GPU篇_第5张图片
    下面显示执行脚本成功
    图片

MindSpore 1.7自动安装 GPU篇_第6张图片

  1. 最后我们来分析下脚本:PYTHON_VERSION=${PYTHON_VERSION:-3.7}MINDSPORE_VERSION=${MINDSPORE_VERSION:EMPTY}CUDA_VERSION=${CUDA_VERSION:-10.1}OPENMPI=${OPENMPI:-off}OPENMPI为on  可以自动安装mpi但是由于我的机器已经安装,所以保留原来的off看自己机器有没有安装mpi可以执行一下mpirun
    MindSpore 1.7自动安装 GPU篇_第7张图片
    上面就代表安装了inimum_driver_version_map["10.1"]="418.39"minimum_driver_version_map["11.1"]="450.80.02"两个cuda分别匹配的显卡驱动版本脚本:# pythonsudo add-apt-repository -y ppa:deadsnakes/ppasudo apt-get install python$PYTHON_VERSION python$PYTHON_VERSION-distutils python3-pip -ysudo update-alternatives --install /usr/bin/python python /usr/bin/python$PYTHON_VERSION 100# pippython -m pip install -U pip -i https://pypi.tuna.tsinghua.edu.cn/simpleecho -e "alias pip='python -m pip'" >> ~/.bashrcpython -m pip config set global.index-url https://pypi.tuna.tsinghua.edu.cn/simple通过APT安装Python3和pip3脚本:# install cuda/cudnnecho "installing CUDA and cuDNN"cd /tmpdeclare -A cuda_url_map=()cuda_url_map["10.1"]=https://developer.download.nvidia.cn/compute/cuda/10.1/Prod/local_installers/cuda_10.1.243_418.87.00_linux.runcuda_url_map["11.1"]=https://developer.download.nvidia.cn/compute/cuda/11.1.1/local_installers/cuda_11.1.1_455.32.00_linux.runcuda_url=${cuda_url_map[$CUDA_VERSION]}wget $cuda_urlsudo sh ${cuda_url##*/} --silent --toolkitcd -sudo apt-key adv --fetch-keys https://developer.download.nvidia.cn/compute/cuda/repos/ubuntu1804/x86_64/7fa2af80.pubsudo add-apt-repository "deb https://developer.download.nvidia.cn/compute/cuda/repos/ubuntu1804/x86_64/ /"sudo add-apt-repository "deb https://developer.download.nvidia.cn/compute/machine-learning/repos/ubuntu1804/x86_64/ /"sudo apt-get updatedeclare -A cudnn_name_map=()cudnn_name_map["10.1"]="libcudnn7=7.6.5.32-1+cuda10.1 libcudnn7-dev=7.6.5.32-1+cuda10.1"cudnn_name_map["11.1"]="libcudnn8=8.0.4.30-1+cuda11.1 libcudnn8-dev=8.0.4.30-1+cuda11.1"sudo apt-get install --no-install-recommends ${cudnn_name_map[$CUDA_VERSION]} -y解析:下载CUDA和cuDNN并安装脚本:sudo apt-get install curl make gcc-7 libgmp-dev linux-headers-"$(uname -r)" -y解析:安装gcc gmp脚本:set +e && source ~/.bashrcset -eadd_env PATH /usr/local/cuda/binadd_env LD_LIBRARY_PATH /usr/local/cuda/lib64add_env LD_LIBRARY_PATH /usr/lib/x86_64-linux-gnuset +e && source ~/.bashrc解析:添加cuda到环境变量if [[ X"$OPENMPI" == "Xon" ]]; then    echo "installing openmpi"    cd /tmp    curl -O https://download.open-mpi.org/release/open-mpi/v4.0/openmpi-4.0.3.tar.gz    tar xzf openmpi-4.0.3.tar.gz    cd openmpi-4.0.3    ./configure --prefix=/usr/local/openmpi-4.0.3    make    sudo make install    add_env PATH /usr/local/openmpi-4.0.3/bin    add_env LD_LIBRARY_PATH /usr/local/openmpi-4.0.3/libfi若是OPENMPI=on就是安装mpirunarch=uname -mpython -m pip install https://ms-release.obs.cn-north-4.myhuaweicloud.com/${MINDSPORE_VERSION}/MindSpore/gpu/${arch}/${cuda_name}/mindspore_gpu-${version_map["$PYTHON_VERSION"]}-linux_${arch}.whl --trusted-host ms-release.obs.cn-north-4.myhuaweicloud.com -i https://pypi.tuna.tsinghua.ed...安装匹配的whl包
    MindSpore 1.7自动安装 GPU篇_第8张图片
    最后安装和执行成功

你可能感兴趣的