pyqt5-tools安装失败的详细处理方法

在准备学习python的PyQt5库时

会遇到pyqt5-tools安装失败的情况。

其中一种可能是版本不适配。

Pycharm弹出显示:安装软件包'pyqt5-tools'时发生错误。

如图:

pyqt5-tools安装失败的详细处理方法_第1张图片

1 D:\Desktop> pip install pyqt5-tools
2 ERROR: qt5-tools 5.15.2.1.2 has requirement click~=7.0, but you'll have click 8.0.4 which is incompatible.
3 ......

略微查看了一下详细信息中的错误代码:

pyqt5-tools安装失败的详细处理方法_第2张图片

pyqt5-tools安装失败的详细处理方法_第3张图片

谷歌翻译如下:

安装构建依赖项:开始
安装构建依赖项:以“完成”状态完成
获得造轮子的要求:开始
获得制造轮子的要求:完成状态“完成”
准备元数据(pyproject.toml):开始
准备元数据(pyproject.toml):以状态“错误”完成

错误:子进程退出错误

准备元数据 (pyproject.toml) 未成功运行。
退出代码:1

注意:此错误源自子进程,可能不是 pip 的问题。
错误:元数据生成失败

生成包元数据时遇到错误。

见上面的输出。

注意:这是上面提到的包的问题,​​而不是 pip。
提示:详见上文。

一头雾水

元数据(‧_‧?)

并不是很懂

连续尝试重新安装了几次并更换安装库都以失败告终

不如尝试一下直接安装.whl文件

找到官方库函数下载地址

pyqt5-tools 官方库下载

搜索pyqt5-tools

选择相关性降序

进入窗口后

(⸮‧_‧)库版本

pyqt5-tools安装失败的详细处理方法_第4张图片

该库目前最终只支持到python3.9

我的python编译器版本3.10

接着去官网下载了个python3.8的编译器

python 编译器下载

并添加到Pycharm中

文件->设置->项目->python解释器->右方小齿轮->添加->基本解释器
file->setting->project->python interpreter->⚙️->add->base interpreter

设置完新的编译器后在python解释器栏同时出现3.8、3.10

pyqt5-tools安装失败的详细处理方法_第5张图片

选择3.8版本的编译器

两种安装方法(库安装和pip安装)任选其一

此处以库安装为例,

文件->设置->项目->python解释器->界面左上角加号(安装)
file->setting->project->python interpreter->Alt+insert

上方搜索框可以直接搜索需要安装的库,若出现安装超时

可能是因为引用的安装库是从国外调用的

可以添加清华镜像或者豆瓣镜像(镜像很多种任选其一就行)

原地址: https://pypi.python.org/simple
清华镜像:https://pypi.tuna.tsinghua.edu.cn/simple/
豆瓣镜像:https://pypi.douban.com/simple/

左下角选择manage repositories(中文选择管理仓库)

左上角选择加号以添加新url,选取上方镜像地址

pyqt5-tools安装失败的详细处理方法_第6张图片

pyqt5-tools安装失败的详细处理方法_第7张图片

接着根据后面镜像地址搜索到的库进行下载即可

pyqt5-tools安装失败的详细处理方法_第8张图片

最后添加成功

除此之外下载超时还有几种情况。。。

pyqt5-tools安装失败的详细处理方法_第9张图片

总结:
1. 如果安装错误,可能是版本对应关系问题
2. 如果安装错误,可以更换编译器(或同时存在多个编译器)
3. 如果安装超时,可能是所连接网络问题
4. 如果安装超时,可以更换镜像以加速下载

到此这篇关于pyqt5-tools安装失败处理的文章就介绍到这了,更多相关pyqt5-tools安装失败内容请搜索脚本之家以前的文章或继续浏览下面的相关文章希望大家以后多多支持脚本之家!

你可能感兴趣的