Tensorflow2.5安装(安装问题,这一篇全解决)

恭喜你发现全网最简单最详细的Tensorflow安装教程!
本文将给出2.5版本的具体配置,若要安装其他版本也可参照本文的思路。

与过去版本对比,你可以感受到来自Tensorflow2.5的善意
①Tensorflow2.1、2.3等版本都缺少Transformer子结构——MultiHeadAttention的相关接口(估计谷歌官方忘记更新这里的API了),经过测试,Tensorflow2.5版本具有MultiHeadAttention的包;
②Tensorflow2.5版本直接附带了keras,不用再pip下载了;
③运行模型不用再修改gpu加速的那段源码了,也就是报错:
(module ‘tensorflow_core._api.v2.config‘ has no attribute ‘experimental_list_devices‘)不会再发生了;
④当然还有很多,总之大大方便了用户

安装步骤概述:
安装Tensorflow-gpu就三步:
①安装Tensorflow
②装Cuda
③下Cudnn,替换Cuda的文件

PS:随着时间的推移,相同的安装方式可能会出现其他问题。如果发生,可以告知博主,会及时测试并更新。

本文目录

  • Tensorflow2.5 GPU相关配置一览
  • 一、Tensorflow 2.5.0安装
    • 1.1 Tensorflow-gpu版本(模型训练快,推荐√)
    • 1.2 Tensorflow-cpu版本(模型训练慢,不推荐)
    • 1.3 安装过程报错全解(欢迎补充)
    • 1.4测试tensorflow安装是否成功
  • 二、Cuda下载和安装
    • **预留补充方案:Cuda卸载
  • 三、Cudnn下载和文件替换
    • 其他Tensorflow版本补充匹配

本文默认已经安装好python,如果没有,最快捷的方式就是安装三件套Anaconda
Anaconda下载安装后,套餐直接附带
①Python
②常用包(很多不需要pip下载了)
③自带编辑器:Jupyter notebook、Spyder(随便选个用)

Tensorflow2.5 GPU相关配置一览

本文安装项目 版本
python 3.6-3.9(博主是3.7.0)
Tensorflow(CPU/GPU) 2.5.0
Cuda(GPU版本所需) 11.2
Cudnn(GPU版本所需) v8.1.0(与Cuda版本匹配即可)

若要安装其他Tensorlfow版本,亦可从→官网这里找。安装方式一样,将Tensorflow、Cuda和Cudnn版本对应好即可,Cudnn最高版本到11.2为止,再高要不兼容了。

Tensorflow2.5安装(安装问题,这一篇全解决)_第1张图片

一、Tensorflow 2.5.0安装

1.1 Tensorflow-gpu版本(模型训练快,推荐√)

推荐,因为多了GPU的资源分配,模型跑的快。
(安装过程可能的错误在1.3给出了,也就是你看到的红色部分,出现的Warning警告(黄色部分)可以忽视。错误修复后,记得重新输入pip命令):

pip install tensorflow-gpu==2.5.0 -i https://pypi.doubanio.com/simple

如果遇到权限受限被拒绝访问的问题,在后面加个–user即可(下同):

pip install tensorflow-gpu==2.5.0 -i https://pypi.doubanio.com/simple --user

1.2 Tensorflow-cpu版本(模型训练慢,不推荐)

去掉上述pip里的“-gpu”即可。如果是CPU版本,安装到此为止。(因为Cuda和Cudnn都是GPU版本所需的)

pip install tensorflow==2.5.0 -i https://pypi.doubanio.com/simple

1.3 安装过程报错全解(欢迎补充)

安装过程基本会报错。最最最重要的是!下列报错只要出现了,就会把那部分安装的内容打断,所以全部修复后记得重新输入Tensorflow的安装命令(因为很重要,所以再提示一次)↓

①You are using pip version 10.0.1, however version 20.2.2 is available.
You should consider upgrading via the ‘python -m pip install --upgrade pip’ command.

解决方案:

python -m pip install --user --upgrade pip

②Cannot uninstall ‘wrapt’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
解决方案:

pip install -U --ignore-installed wrapt enum34 simplejson netaddr

③twisted 18.7.0 requires PyHamcrest>=1.9.0, which is not installed.
解决方案:

pip install PyHamcrest

④google-auth 1.20.1 has requirement setuptools>=40.3.0, but you’ll have setuptools 40.2.0 which is incompatible.
tensorboard 2.1.1 has requirement setuptools>=41.0.0, but you’ll have setuptools 40.2.0 which is incompatible.

解决方案:

python -m pip install -U pip setuptools

⑤ImportError: DLL load failed: 找不到指定的模块。
解决方案:导入tensorflow这个错误两台电脑有遇到(1/2),用Vc 2015解决,文件名称VC_redist.x64.exe(直接点进去不断下一步即可)

链接:https://pan.baidu.com/s/1CneXLwODtGRBmgUtp7VxDQ
提取码:f42m

1.4测试tensorflow安装是否成功

这里可以简单检测下
输入

python
import tensorflow

pip安装完后可以测试下,出现下列提示那就OK。
提示的意思就是:Cuda还没装
Tensorflow2.5安装(安装问题,这一篇全解决)_第2张图片
下面继续

二、Cuda下载和安装

Cuda下载

安装注意点:
①Windows系统有更新,就先更新系统,否则Cuda会安装失败(亲身经历)。
②对于Cuda的安装,别想那么多,直接下一步,用默认安装(即装在C盘)。因为无论选D盘还是E盘最后都会给你塞到C盘。就会有人误以为自己操作不当删了又装,白白浪费时间。
③先检测自己的显卡适不适合高版本的cuda,兼容11.2及以下版本(这里会发现这条代码也会给你Tensorflow对应的CUDA版本提示)
命令:

nvidia-smi

Tensorflow2.5安装(安装问题,这一篇全解决)_第3张图片

这里建议选择11.2.0版本(其他版本还未测试过)的Cuda。
Tensorflow2.5安装(安装问题,这一篇全解决)_第4张图片
Tensorflow2.5安装(安装问题,这一篇全解决)_第5张图片
下载直接安装即可(如果前面有安装过其他版本的,先卸载)。

**预留补充方案:Cuda卸载

如果不慎安装了错误版本的Cuda,重新安装前务必把之前的卸载干净。
cuda卸载方式:
以windows为例,
直接搜索
在这里插入图片描述
找到
Tensorflow2.5安装(安装问题,这一篇全解决)_第6张图片
保留圈中的两个,其余全部手动卸载。
Tensorflow2.5安装(安装问题,这一篇全解决)_第7张图片

三、Cudnn下载和文件替换

Cudnn下载地址
有很多版本,选了个兼容Cuda 11.2,因为前面高版本出错问题多的缘故,最终选择出现早的版本
Tensorflow2.5安装(安装问题,这一篇全解决)_第8张图片

下载完后解压会发现Cudnn里面其实就是三个文件夹,复制他们(bin+include+lib),然后进入cuda安装位置(由于默认安装位置,在C盘),右键黏贴进行替换。

把Cudnn下好的三个文件替换cuda\v11.2下的三个同名文件即可完成。

Tensorflow2.5安装(安装问题,这一篇全解决)_第9张图片
最后,进入终端再测试一下(别想复杂,其实就是在python环境下运行下,这里可以的话,也就代表编辑器运行的时候gpu可以加速)
输入

python
import tensorflow as tf
print(tf.test.is_gpu_available())

为True代表成功了,也即GPU可加速。

如果为False,首先前面安装过程确认无误。

收集了一些网友反馈的解决方式:
①可以试着重启电脑。有时候一些配置重启后才能有效。——遇到一次重启解决的
②Cudnn替换的过程注意最近文件操作的日期,因为电脑差异或者设置的问题,可能替换文件不会覆盖掉已存在的文件,所以可以试着删掉文件夹(备份当然是最稳妥的),再黏贴)
结果如下:测试成功
Tensorflow2.5安装(安装问题,这一篇全解决)_第10张图片
运行代码,疯狂加速,很ok!( •̀ ω •́ )甚至无敌
Tensorflow2.5安装(安装问题,这一篇全解决)_第11张图片

其他Tensorflow版本补充匹配

Tensorflow2.1、2.3 (Cuda和Cudnn版本通用)

安装项目 版本
Tensorflow(GPU) 2.1.0 /2.3.0
Cuda(GPU版本所需) 10.1
Cudnn(GPU版本所需) v7.6.5
Keras 2.3.1

你可能感兴趣的