ubuntu18.04 安装搜狗输入法

先说一下问题,我重装了Ubuntu18.04系统,相当于是第一次安装搜狗输入法,去官网下载linux最新的安装包,按照网上的教程全部配置了一遍,然后发现打不了中文。最终我在这篇文章下,换了一个搜狗输入法的安装包,没用官网最新的。

不要下载官网最新的!!

安装搜狗输入法可以参考这个链接

Ubuntu18.04安装搜狗输入法-问题全讲解_幻心矢的博客-CSDN博客_ubuntu18.04 安装搜狗输入法

我这里直接挂一下下载搜狗输入法的包复制到浏览器就能下载

http://cdn2.ime.sogou.com/dl/index/1524572264/sogoupinyin_2.2.0.0108_amd64.deb?st=Sqqig96zYSljSkECfFta0w&e=1544890690&fn=sogoupinyin_2.2.0.0108_amd64.deb

下载完成后,终端输入,最后的.deb写你自己下载包的名字

     sudo dpkg -i sogoupinyin_2.1.0.0082_amd64.deb

这时候报错:

dpkg: dependency problems prevent configuration of sogoupinyin:
 sogoupinyin depends on libopencc2 | libopencc1; however:
  Package libopencc2 is not installed.
  Package libopencc1 is not installed.
 sogoupinyin depends on libqtwebkit4 (>= 2.1.0~2011week13); however:
  Package libqtwebkit4 is not installed.

没关系,输入下面这行命令,会把缺少的依赖库都安装一下

sudo apt install -f

然后重新输入

     sudo dpkg -i sogoupinyin_2.1.0.0082_amd64.deb

完成。

剩下的随便找个教程都可以解决问题。

卸载搜狗输入法参考这个

ubuntu安装与卸载搜狗输入法_最Hhig的放肆的博客-CSDN博客_ubuntu卸载搜狗输入法

你可能感兴趣的