解决maven maven.compiler.source和maven.compiler.target的坑

maven maven.compiler.source和maven.compiler.target的坑

最近建议产品组把jdk 1.7升级到1.8,昨晚开发报了个问题过来,说maven.compiler.source和maven.compiler.target改成1.8之后,编译出来的代码还是1.7,如下:

解决maven maven.compiler.source和maven.compiler.target的坑_第1张图片

也可通过javap -v ServiceImpl.class 查看class文件的java编译版本号。

下午抽空看了下,果不其然,第一怀疑就是maven.compiler.source和maven.compiler.target这两参数不靠谱。

看了下,IDE配置的JDK

如下:

解决maven maven.compiler.source和maven.compiler.target的坑_第2张图片

自动build之后,的确是jdk 1.7

如下:

解决maven maven.compiler.source和maven.compiler.target的坑_第3张图片

换成J2SE-1.8

解决maven maven.compiler.source和maven.compiler.target的坑_第4张图片

解决maven maven.compiler.source和maven.compiler.target的坑_第5张图片

换成1.6

解决maven maven.compiler.source和maven.compiler.target的坑_第6张图片

解决maven maven.compiler.source和maven.compiler.target的坑_第7张图片

查询maven官方文档,可知maven.compiler.source和maven.compiler.target仅仅是推荐,不是强制。

如果要强制jdk版本

可指定executable属性来保证,如下:


  [...]
  
    [...]
    
      
        org.apache.maven.plugins
        maven-compiler-plugin
        3.7.0
        
          true
          true
          
          1.3
        
      
    
    [...]
  
  [...]

问题解决。

maven编译报错java: -source,pom设置maven.compiler.source原理

我们编译的插件Maven compiler Plugin就是用来编译代码的,以前刚学java的时候,使用javac 命令编译.java文件为.class文件.

而设置

   ${java.version}
    ${java.version}

就是指定javac-source与target选项的,官网

解决maven maven.compiler.source和maven.compiler.target的坑_第8张图片

有时候,maven编译报错java: -source 1.5 中不支持 diamond 运算符就是因为没有指定编译版本.指定版本即可

以上为个人经验,希望能给大家一个参考,也希望大家多多支持脚本之家。

你可能感兴趣的