实习日记1:跨vlan通信

跨vlan通信

1.拓扑图:实习日记1:跨vlan通信_第1张图片
2.要求:不同vlan的两台pc通过二层交换机实现二层互通
3.命令:

[H3C-GigabitEthernet2/0/1]port link-type hybrid              把端口模式改为hydrid
[H3C-GigabitEthernet2/0/1]port hybrid vlan 2 untagged        VLAN2的帧以Untagged的方式通过接口。(不带标签,允许该标签进入交换机,同时打上端口的pvid的vlan号,本题中对于带2的帧,会让帧通过,命令行中没出现的vlan x号直接丢弃)
[H3C-GigabitEthernet2/0/1]port hybrid vlan 3 untagged        VLAN3的帧以Untagged 的方式通过接口。

另一个口同上操作:
[H3C-GigabitEthernet2/0/2]port link-type hybrid
[H3C-GigabitEthernet2/0/2]port hybrid vlan 2 untagged
[H3C-GigabitEthernet2/0/2]port hybrid vlan 3 untagged

思考:用在上面图中加一个二层交换机,怎么实现pc2和pc3的通信?
提示:trunk

interface GigabitEthernet2/0/1                  进入端口
port access vlan 2                              把端口划入vlan2
interface GigabitEthernet2/0/2
port access vlan 3
interface GigabitEthernet2/0/23                 进入端口
port link-type trunk                            把端口改为trunk口
port trunk permit vlan all                      允许所有vlan口通过
port trunk pvid vlan 2                          trunk的pvid为当前所处的vlan2
interface GigabitEthernet2/0/23
port link-type trunk
port trunk permit vlan all
port trunk pvid vlan 3

归纳总结:

1.access,trunk,hybrid区别:
实习日记1:跨vlan通信_第2张图片

2.Tag与untag分析

Port hybrid tagged vlan 2 4
Port hybrid untagged vlan 3 5

当交换机接收到一个来自其他设备的以太网帧,首先查看该帧是否带了标签(即vlan信息)

  1. 如果不带标签(pc或其他设备发送时剥离了标签)允许该标签进入交换机,同时打上该端口的PVID的vlan号。该帧从不带标签到带标签。
  2. 如果带标签,那么首先查看该帧所带vlan号是否在所敲命令中出现。若出现则通过,反之,丢弃。
    例如3出现,通过;6没出现,丢弃

当交换机发送一个以太帧出去时
对于tagged定义的帧,端口会直接发送,不会做任何修改。例如帧4
对于untagged定义的帧,会剥离该帧的标签,该帧从带标签到不带标签。例如帧5

总结:tagged与untagged定义的帧,只有在发送时有剥离或不剥离的区别,在接收帧的时候,只会起一个判断是否允许该帧通过的作用(定义了则允许通过,未定义则丢弃)

你可能感兴趣的