虚拟机+Ubuntu18.04+CoppeliaSim

目录

1.官网下载CoppeliaSim_Edu_V4_1_0_Ubuntu18_04

2.安装ROS

3.安装catkin


本文讲述本人在安装CoppeliaSim的时候所遇到的各种问题以及解决办法,此外这是本人第一次尝试通过博客来分享自己学到的东西,如有错误烦请读者指出。

1.官网下载CoppeliaSim_Edu_V4_1_0_Ubuntu18_04

先到Coppeliasim官网下载所需版本的Coppeliasim,我这里下载的是CoppeliaSim_Edu_V4_1_0_Ubuntu18_04版本。(我一开始打算下载4.2.0版本,但是在后续的过程中会报错,所以我就只下载了4.1.0的)此外,学长建议下载Edu版本的,因为Edu版本比player版本功能更多一些。

在等待下载完成的时候我们可以先创建一个文件夹来存放coppeliasim:

mkdir -p sim_ws/src

下载完成后解压并将解压好的coppeliasim文件直接拖的src文件中。

此时在终端进入安装好的coppeliasim文件夹下,输入./coppeliaSim.sh就可以打开coppeliasim看到打开效果:

2.安装ROS

现在的Coppeliasim虽然可以运行,但是并不能进行ROS通信,需要搭建bridge:

cd ~/sim_ws/src
git clone --recursive https://github.com/CoppeliaRobotics/simExtROS.git sim_ros_interface
#如果clone的时候报错,可以尝试多试几次
cd sim_ros_interface
git checkout coppeliasim-v4.1.0
cd ~/sim_ws
catkin build -j4

最开始不是说安装4.2.0版本会报错嘛(会说什么找不到Coppeliasim 4.1.0啥的),这里解释一下。 

#上面的代码中有一句为:
git clone --recursive https://github.com/CoppeliaRobotics/simExtROS.git sim_ros_interface

 我们进入到链接(GitHub - CoppeliaRobotics/simExtROS)中可以看到:

虚拟机+Ubuntu18.04+CoppeliaSim_第1张图片

虚拟机+Ubuntu18.04+CoppeliaSim_第2张图片

上面显示现在只能find_package(CoppeliaSim 4.1.0.0 REQUIRED),所以装4.2.0的时候会报错。

如果成功执行完毕(即执行catkin build -j4之后不报错),就可以不再往下看了。

如果在执行catkin build -j4时,报错说没有catkin这个命令,则继续往下看第三部分。

3.安装catkin

由于这一块都是自己摸索的,所以可能中间会有问题,比如说下面的两段代码,虽然我都执行了,但可能只需要执行第二段就可以了(我只是说可能哈),有问题的话烦请大家指出。

如果在执行catkin的时候报错说找不到catkin表明没有catkin,这时候就需要下载catkin,这里我采用catkin命令安装_二毛的博客-CSDN博客_catkin安装中的做法:

sudo apt-get update
sudo apt-get install python-catkin-tools
catkin init

我按照上述代码执行的时候报错:Ubuntu中安装ROS提示无法定位软件包,然后我采用了文章Ubuntu中安装ROS提示无法定位软件包_zyc_csdn的博客-CSDN博客中的的做法,将软件源换成国内的再下载.(PS,由于文章中的密匙好像失效了,我就在网上找了其他的密匙来替换),代码综合起来如下:

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv F42ED6FBAB17C654
#如果这个密匙也不行的话可以到网上搜其他的
sudo apt-get update
sudo apt-get install ros-melodic-desktop-full

sudo rosdep init
rosdep update

echo "source /opt/ros/melodic/setup.bash" >> ~/.bashrc
source ~/.bashrc

在执行sudo rosdep initrosdep update的时候有可能会报如下错误:

ERROR: cannot download default sources list from:
https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list
Website may be down.

为解决上述错误, 我采用rosdep init/update 解决方法_CCsherlock的博客-CSDN博客提到的方法来解决,最后就可以成功的rosdep update了。(PS,这里前半段的操作就是为了避免rosdep init所带来的报错,所以最后就没有rosdep init而是直接rosdep update

此外,我在运行source ~/.bashrc 的时候遇到了问题说找不到 source /opt/ros/melodic/setup.bash文件,网上找了都没有解决,最后我到melodic文件夹下面看了一下,原来是没有setup.bash文件,所以我直接重新执行了sudo apt-get install ros-melodic-desktop-full,然后就不报错了。

现在应该就可以执行catkin build -j4啦。

参考文章:​​​​​​CoppeliaSim学习笔记之CoppeliaSim Edu V4.1.0 + Ubuntu 16.04 + ROS Kinetic环境搭建与基础测试_知不道道不知知不知道道道知的博客-CSDN博客_coppeliasim edu

 Ubuntu中安装ROS提示无法定位软件包_zyc_csdn的博客-CSDN博客

rosdep init/update 解决方法_CCsherlock的博客-CSDN博客

catkin命令安装_二毛的博客-CSDN博客_catkin安装

你可能感兴趣的