使用eNSP搭建的小型校园网

本项目所需软件eNSP_Setup、VirtualBox-5.2.38-136252-Win、WinPcap_4_1_3、Wireshark-win64-3.2.2

1.1 设计任务

组建小型校园网:学生宿舍50台计算机、办公楼30台计算机(办公楼又分为财务处、人事处,以及其他科室)、图书馆10台计算机、教学楼30台计算机、服务器2台(FTP、Web),学校通过一台路由器连接到服务器和Internet。

1.2 需求分析

1.每个部门内部可以二层互通、部门间可以三层互通。

2.使用静态路由、RIP路由配置。

3.校园内部使用私网IP地址,所有用户均可通过校园网访问Internet。

4.所有用户均可在内网实现资源共享,访问Web/FTP服务器。

5.学生宿舍、图书馆、教学楼不能访问人事处、财务处。

6.服务器采用静态IP地址,其他用户采用动态IP地址。

1.3 网络规划/设计

1.3.1VLAN规划

分别在学生宿舍、图书馆、教学楼下设置一台主机和一台Client为代表,以实现二层之间的互通。在办公楼下设置三个交换机,每个交换机下设置一台主机和一台Client为代表,以实现二层之间的互通。

使用一个聚合交换机进行配置,代表教学楼,以实现三层之间可以实现互通。同时满足要求学生宿舍、图书馆、教学楼不能访问人事处、财务处。

1.3.2IP地址规划

以下为IP地址规划
使用eNSP搭建的小型校园网_第1张图片

1.3.3功能部署规划

校园网整体布局
使用eNSP搭建的小型校园网_第2张图片

学生宿舍由一个交换机、一台主机和一台Client构成,配置的

VLAN为VLAN10,可以访问图书馆和教学楼
使用eNSP搭建的小型校园网_第3张图片

图书馆由一个交换机、一台主机和一台Client构成,配置的VLAN为VLAN50,可以访问学生宿舍和教学楼
使用eNSP搭建的小型校园网_第4张图片

教学楼由一个交换机、一台主机和一台Client构成,配置的VLAN为VLAN60,可以访问图书馆和学生宿舍
使用eNSP搭建的小型校园网_第5张图片

办公楼由一个聚合交换机代表,其他为三个普通交换机,分别代表财务处、人事处和其他科室,每个部分又分别有一台主机和一台Client代表。

可以实现财务处、人事处、其他科室三个部分互通,并且学生宿舍、图书馆、教学楼均不能访问人事处、财务处。
使用eNSP搭建的小型校园网_第6张图片

Internet和Web/FTP服务器分别用一台主机和一台服务器来代表,可以实现校园内部使用私网IP地址,所有用户均可通过校园网访问Internet以及所有用户均可在内网实现资源共享,访问Web/FTP服务器两大功能。
使用eNSP搭建的小型校园网_第7张图片

1.4 具体配置

1.4.1配置VLAN——在接入交换机上配置

分别在LSW1-LSW6上配置VLAN,然后配置入口类型为access,将主机默认vlan设置成配置的vlan,并且将出口设置为trunk类型,设置出口的vlan为默认预设的vlan

LSW1

vlan batch 10
interface Ethernet 0/0/1
port link-type access
port default vlan 10
quit
interface Ethernet 0/0/2
port link-type access
port default vlan 10
quit
interface Ethernet 0/0/4
port link-type trunk
port trunk allow-pass vlan 10
quit

LSW2

vlan batch 20
interface Ethernet 0/0/3
port link-type access
port default vlan 20
quit
interface Ethernet 0/0/4
port link-type access
port default vlan 20
quit
interface Ethernet 0/0/2
port link-type trunk
port trunk allow-pass vlan 20
quit

LSW3

vlan batch 30
interface Ethernet 0/0/5
port link-type access
port default vlan 30
quit
interface Ethernet 0/0/6
port link-type access
port default vlan 30
quit
interface Ethernet 0/0/4
port link-type trunk
port trunk allow-pass vlan 30
quit

LSW4

vlan batch 40
interface Ethernet 0/0/7
port link-type access
port default vlan 40
quit
interface Ethernet 0/0/8
port link-type access
port default vlan 40
quit
interface Ethernet 0/0/5
port link-type trunk
port trunk allow-pass vlan 40
quit

LSW5

vlan batch 50
interface Ethernet 0/0/9
port link-type access
port default vlan 50
quit
interface Ethernet 0/0/10
port link-type access
port default vlan 50
quit
interface Ethernet 0/0/6
port link-type trunk
port trunk allow-pass vlan 50
quit

LSW6

vlan batch 60
interface Ethernet 0/0/11
port link-type access
port default vlan 60
quit
interface Ethernet 0/0/12
port link-type access
port default vlan 60
quit
interface Ethernet 0/0/7
port link-type trunk
port trunk allow-pass vlan 60
quit

1.4.2在路由器上配置VLAN10、50、60

在AR1路由器上配置VLAN10、50、60,以实现学生宿舍、图书馆和教学楼之间可以进行部门间的三层访问。
首先,批量创建VLAN10、50、60,设置接口类型为access,将默认VLAN设置成预设的VLAN,然后将出口类型设置为trunk,将默认VLAN设置成预设,使其通过。
同时创建一个VLAN100,目的是为了给办公楼进行使用。

vlan batch 10
interface Ethernet 0/0/4
port link-type trunk
port trunk allow-pass vlan 10
quit
vlan batch 50
interface Ethernet 0/0/6
port link-type trunk
port trunk allow-pass vlan 50
quit
vlan batch 60
interface Ethernet 0/0/7
port link-type trunk
port trunk allow-pass vlan 60
quit
vlan batch 100
interface Ethernet 0/0/5
port link-type trunk
port trunk allow-pass vlan 100
quit

1.4.3配置VLAN10、50、60路由——路由器

给学生宿舍、图书馆、教学楼配置路由,使HDCP能够动态获取路由,并且使得学生宿舍、图书馆、教学楼之间可以相互ping通。

interface vlanif 10
ip address 192.168.1.1 24
quit
interface vlanif 50
ip address 192.168.5.1 24
quit
interface vlanif 60
ip address 192.168.6.1 24
quit
dhcp enable
interface vlanif 10
dhcp select interface
quit
dhcp enable
interface vlanif 50
dhcp select interface
quit
dhcp enable
interface vlanif 60
dhcp select interface
quit

配置结果学生宿舍、图书馆和教学楼之间可以相互ping通

学生宿舍ping图书馆、教学楼
使用eNSP搭建的小型校园网_第8张图片

图书馆ping学生宿舍、教学楼
使用eNSP搭建的小型校园网_第9张图片

教学楼ping学生宿舍、图书馆
使用eNSP搭建的小型校园网_第10张图片

1.4.4在汇聚交换机LSW7上创建VLAN

在LSW7上批量创建VLAN20、30、40、100,将每一个通过GigabitEthernet接口与LSW7相连的交换机链路上配置接口类型为access,将默认VLAN设置为预设的20、30、40。

LSW7

vlan batch 20 30 40 100
interface GigabitEthernet 0/0/2
port link-type trunk
port trunk allow-pass vlan 20
quit
interface GigabitEthernet 0/0/4
port link-type trunk
port trunk allow-pass vlan 30
quit
interface GigabitEthernet 0/0/5
port link-type trunk
port trunk allow-pass vlan 40
quit
interface GigabitEthernet 0/0/1
port link-type trunk
port trunk allow-pass vlan 100
quit

1.4.5在汇聚交换机LSW7上配置路由

在三个VLANIF中分别配置每一个路由地址

LSW7

interface vlanif 20
ip address 192.168.2.1 24
quit
interface vlanif 30
ip address 192.168.3.1 24
quit
interface vlanif 40
ip address 192.168.4.1 24
quit
interface vlanif 100
ip address 192.168.100.1 24
quit
rip 100
network 192.168.2.0
network 192.168.3.0
network 192.168.4.0
network 192.168.100.0
quit

1.4.6配置DHCP---配置DHCP中继

在LSW7上配置DHCP中继,在LSW7上使能DHCP功能,然后在LSW7上,使能DHCP relay功能并且指定中继到的DHCP服务器地址。

LSW7

dhcp enable
interface vlanif 20
dhcp select relay
dhcp relay server-ip 192.168.100.2
quit
interface vlanif 30
dhcp select relay
dhcp relay server-ip 192.168.100.2
quit
interface vlanif 40
dhcp select relay
dhcp relay server-ip 192.168.100.2
quit

1.4.7配置DHCP---配置DHCP服务器

在DHCP服务器上AR1上使能DHCP功能,然后分别配置全局地址池pool2、pool3、pool4。进入连接下方LSW7的VLANIF 100接口,并且使能全局地址池功能。

AR1

dhcp enable
ip  pool pool2
network 192.168.2.0 mask 255.255.255.0
gateway-list 192.168.2.1
quit
ip  pool pool3
network 192.168.3.0 mask 255.255.255.0
gateway-list 192.168.3.1
quit
ip  pool pool4
network 192.168.4.0 mask 255.255.255.0
gateway-list 192.168.4.1
quit
interface vlanif 100
dhcp select global
quit

配置结果,财务处、人事处、其他科室可以相互ping通

财务处ping人事处、其他科室
使用eNSP搭建的小型校园网_第11张图片

人事处ping财务处、其他科室
使用eNSP搭建的小型校园网_第12张图片

其他科室ping财务处、人事处
使用eNSP搭建的小型校园网_第13张图片

1.4.8实现资源共享

实现资源共享,使得所有用户均可通过校园网访问Web/FTP服务器,也是Server1,IP网关为200.1.1.1。

首先需要在AR1上将直连路由加入其中

interface vlanif 100
ip address 192.168.100.2 24
quit
rip 100
network 192.168.100.0
network 192.168.1.0
network 192.168.5.0
network 192.168.6.0
quit

然后在AR1路由器和Web/FTP服务器连接的路由上配置VLAN,并且在VLANIF中配置网络地址。将配置的地址加入rip当中进行广播。

AR1

vlan batch 1000
interface Ethernet 0/0/1
port link-type access
port default vlan 1000
quit
interface vlanif 1000
ip address 200.1.1.1 24
quit
rip 100
network 200.1.1.0
quit

在AR2路由器上配置VLAN,并且将接口类型设置为access。默认VALN设置为预设的200

AR2

vlan batch 200
interface Ethernet 0/0/1
port link-type access
port default vlan 200
quit

在AR1的GigabitEthernet 0/0/1接口上配置一个IP地址

AR1

interface GigabitEthernet 0/0/1
ip address 150.1.1.1 24
quit

在AR2上配置VLANIF中的地址,并且给GigabitEthernet 0/0/1配置一个IP地址

AR2

interface vlanif 200
ip address 100.1.1.1 24
quit
interface GigabitEthernet 0/0/1
ip address 150.1.1.2 24
quit

AR 1和AR2分别配置连通对方的静态地址

ip route-static 0.0.0.0 0.0.0.0 150.1.1.2
ip route-static 0.0.0.0 0.0.0.0 150.1.1.1

现在PC1-PC6都可以实现访问Web/FTP服务器的功能

PC1
使用eNSP搭建的小型校园网_第14张图片

PC2
使用eNSP搭建的小型校园网_第15张图片

PC3
使用eNSP搭建的小型校园网_第16张图片

PC4
使用eNSP搭建的小型校园网_第17张图片

PC5
使用eNSP搭建的小型校园网_第18张图片

PC6
使用eNSP搭建的小型校园网_第19张图片

1.4.9配置NAT

配置NAT需要配置先配置不同的地址组,分配不同的地址。然后配置不同的acl,分配不同的acl,最后早AR1的interface GigabitEthernet0/0/1上将不同的IP地址组和不同的acl相对应起来。此外。还需要在LSW7上配置一个静态路由。

LSW7

ip route-static 0.0.0.0 0.0.0.0 192.168.100.2

AR1

nat address-group 1 150.1.1.100 150.1.1.200
nat address-group 2 150.2.1.100 150.2.1.200
nat address-group 3 150.3.1.100 150.3.1.200
nat address-group 4 150.4.1.100 150.4.1.200
nat address-group 5 150.5.1.100 150.5.1.200
nat address-group 6 150.6.1.100 150.6.1.200
acl 2001
rule permit source 192.168.1.2 0.0.0.255
quit
acl 2002
rule permit source 192.168.2.2 0.0.0.255
quit
acl 2003
rule permit source 192.168.3.2 0.0.0.255
quit
acl 2004
rule permit source 192.168.4.2 0.0.0.255
quit
acl 2005
rule permit source 192.168.5.2 0.0.0.255
quit
acl 2006
rule permit source 192.168.6.2 0.0.0.255
quit
interface GigabitEthernet0/0/1
nat outbound 2001 address-group 1 no-pat
nat outbound 2002 address-group 2 no-pat
nat outbound 2003 address-group 3 no-pat
nat outbound 2004 address-group 4 no-pat
nat outbound 2005 address-group 5 no-pat
nat outbound 2006 address-group 6 no-pat
quit

现在PC1-6均可以访问Internet
PC1
使用eNSP搭建的小型校园网_第20张图片

PC2
使用eNSP搭建的小型校园网_第21张图片

PC3
使用eNSP搭建的小型校园网_第22张图片

PC4
使用eNSP搭建的小型校园网_第23张图片

PC5
使用eNSP搭建的小型校园网_第24张图片

PC6
使用eNSP搭建的小型校园网_第25张图片

1.4.10配置学生宿舍、图书馆和教学楼不能访问人事处、财务处和其他科室

通过配置ACL,使得学生宿舍、图书馆和教学楼不能访问人事处、财务处和其他科室。

配置一个acl3000,将具体的地址制定为规则,然后在LSW7的接口下应用其规则。

acl 3000
rule 1 deny ip source 192.168.1.1 0.0.0.255 destination 192.168.2.1 0.0.0.255
rule 2 deny ip source 192.168.1.1 0.0.0.255 destination 192.168.3.1 0.0.0.255
rule 3 deny ip source 192.168.1.1 0.0.0.255 destination 192.168.4.1 0.0.0.255
rule 4 deny ip source 192.168.5.1 0.0.0.255 destination 192.168.2.1 0.0.0.255
rule 5 deny ip source 192.168.5.1 0.0.0.255 destination 192.168.3.1 0.0.0.255
rule 6 deny ip source 192.168.5.1 0.0.0.255 destination 192.168.4.1 0.0.0.255
rule 7 deny ip source 192.168.6.1 0.0.0.255 destination 192.168.2.1 0.0.0.255
rule 8 deny ip source 192.168.6.1 0.0.0.255 destination 192.168.3.1 0.0.0.255
rule 9 deny ip source 192.168.6.1 0.0.0.255 destination 192.168.4.1 0.0.0.255
quit
interface vlanif100
traffic-filter outbound acl 3000
quit

PC1,5,6不能访问PC2,3,4
使用eNSP搭建的小型校园网_第26张图片
使用eNSP搭建的小型校园网_第27张图片
使用eNSP搭建的小型校园网_第28张图片

PC2,3,4可以访问PC1,5,6
使用eNSP搭建的小型校园网_第29张图片
使用eNSP搭建的小型校园网_第30张图片
使用eNSP搭建的小型校园网_第31张图片

1.5 测试验证

1.5.1每台网络设备的路由表

下方给出每台网络设备的路由表(汇聚交换机/出口路由器)

输入在LSW7、AR1、AR2上使用display ip routing-table命令查看路由表

LSW7的路由配置表
使用eNSP搭建的小型校园网_第32张图片
AR1路由配置表
使用eNSP搭建的小型校园网_第33张图片
AR2
使用eNSP搭建的小型校园网_第34张图片

1.5.2验证结果

1.5.2.1每个部门内部可以二层互通

学生宿舍
使用eNSP搭建的小型校园网_第35张图片

财务处
使用eNSP搭建的小型校园网_第36张图片

人事处
使用eNSP搭建的小型校园网_第37张图片

其他科室
使用eNSP搭建的小型校园网_第38张图片

图书馆
使用eNSP搭建的小型校园网_第39张图片

教学楼
使用eNSP搭建的小型校园网_第40张图片

1.5.2.2部门间可以三层互通

学生宿舍ping图书馆、教学楼
使用eNSP搭建的小型校园网_第41张图片

图书馆ping学生宿舍、教学楼
使用eNSP搭建的小型校园网_第42张图片

教学楼ping学生宿舍、图书馆
使用eNSP搭建的小型校园网_第43张图片

财务处ping人事处、其他科室
使用eNSP搭建的小型校园网_第44张图片

人事处ping财务处、其他科室
使用eNSP搭建的小型校园网_第45张图片

其他科室ping财务处、人事处
使用eNSP搭建的小型校园网_第46张图片

1.5.2.3学生宿舍、图书馆、教学楼不能访问人事处财务处其他科室

学生宿舍不能访问人事处、财务处、其他科室
使用eNSP搭建的小型校园网_第47张图片

图书馆不能访问人事处、财务处、其他科室
使用eNSP搭建的小型校园网_第48张图片

教学楼不能访问人事处、财务处、其他科室
使用eNSP搭建的小型校园网_第49张图片

并且财务处、人事处和其他科室都可以访问学生宿舍、图书馆和教学楼
使用eNSP搭建的小型校园网_第50张图片
使用eNSP搭建的小型校园网_第51张图片
使用eNSP搭建的小型校园网_第52张图片

1.5.2.4服务器采用静态IP地址

Web/FTP服务器
使用eNSP搭建的小型校园网_第53张图片

Internet
使用eNSP搭建的小型校园网_第54张图片

1.5.2.5其他用户采用动态IP地址

PC1
使用eNSP搭建的小型校园网_第55张图片

PC2
使用eNSP搭建的小型校园网_第56张图片

PC3
使用eNSP搭建的小型校园网_第57张图片

PC4
使用eNSP搭建的小型校园网_第58张图片

PC5
使用eNSP搭建的小型校园网_第59张图片

PC6
使用eNSP搭建的小型校园网_第60张图片

1.5.2.6所有用户均可通过校园网访问Internet

PC1-6均可以访问Internet

PC1
使用eNSP搭建的小型校园网_第61张图片

PC2
使用eNSP搭建的小型校园网_第62张图片

PC3
使用eNSP搭建的小型校园网_第63张图片

PC4
使用eNSP搭建的小型校园网_第64张图片

PC5
使用eNSP搭建的小型校园网_第65张图片

PC6
使用eNSP搭建的小型校园网_第66张图片

1.5.2.7所有用户均可在内网实现资源共享,访问Web/FTP服务器

PC1
使用eNSP搭建的小型校园网_第67张图片

PC2
使用eNSP搭建的小型校园网_第68张图片

PC3
使用eNSP搭建的小型校园网_第69张图片

PC4
使用eNSP搭建的小型校园网_第70张图片

PC5
使用eNSP搭建的小型校园网_第71张图片

PC6
使用eNSP搭建的小型校园网_第72张图片

1.6 小结

1.6.1课程设计的心得

两周的课程设计结束了,在这次的课程设计中不仅检验了我所学习的知识,也培养了我如何去把握一件事情,如何去做一件事情,又如何完成一件事情。在设计过程中,与同学分工设计,和同学们相互探讨,相互学习,相互监督。学会了合作,学会了运筹帷幄,学会了宽容,学会了理解,也学会了做人与处世。

课程设计是我们专业课程知识综合应用的实践训练,着是我们迈向社会,从事职业工作前一个必不少的过程.”千里之行始于足下”,通过这次课程设计,我深深体会到这句千古名言的真正含义,我今天认真的进行课程设计,学会脚踏实地迈开这一步,就是为明天能稳健地在社会大潮中奔跑打下坚实的基础.

通过这次课程设计,本人在多方面都有所提高。通过这次设计,综合运用本专业所学课程的理论和生产实际知识进行一次小型校园网设计工作的实际训练从而培养和提高学生独立工作能力,巩固与扩充了计算机网络等课程所学的内容,掌握网络规划设计的方法和步骤,掌握VLAN、ACL、NAT设计的基本的技能,懂得了怎样分析网络复杂性,怎样确定设计方案,了解了网络的基本结构,提高了配置网络能力,绘图能力,熟悉了规范和标准,同时有了全面的复习,独立思考的能力也有了提高。

1.6.2收获

在这次设计过程中,体现出自己设计网络的能力以及综合运用知识的能力,体会了学以致用、突出自己劳动成果的喜悦心情,从中发现自己平时学习的不足和薄弱环节,从而加以弥补。

在此感谢我们的计算机网络老师.,老师严谨细致、一丝不苟的作风一直是我工作、学习中的榜样;老师循循善诱的教导和不拘一格的思路给予我无尽的启迪;这次网络设计的每个实验细节,都离不开老师您的细心指导。而您开朗的个性和宽容的态度,帮助我能够很顺利的完成了这次课程设计。

同时感谢对我帮助过的同学们,谢谢你们对我的帮助和支持,让我感受到同学的友谊。

1.6.3不足分析

由于本人的设计能力有限,在设计过程中难免出现错误,恳请老师们多多指教,我十分乐意接受你们的批评与指正,本人将万分感谢。

你可能感兴趣的