2021-01-21 Module build failed (from ./node_modules/css-loader/dist/cjs.js)

若依框架,前端运行npm run build:prod打包失败,报很多error,其中有Module build failed (from ./node_modules/css-loader/dist/cjs.js) 等等

解决方法:

  1. package.json中删除 "css-loader": "^3.5.3",因为已经有
    "sass-loader": "8.0.2","node-sass": "4.14.1"了,可能冲突了,具体原因我没有分析
  2. 删除node-mudles文件夹
    3.npm rebuild node-sass
    4.执行npm install

然后就打包成功了

你可能感兴趣的