OSS is not defined? 检查检查你依赖的core-js吧

事情是这样的

第一天

小李是一家互联网公司的前端,有一天他闲来无事看到项目的vue-cli依赖版本还是3.0.0-rc,一股升级依赖的使命感涌上心头
OSS is not defined? 检查检查你依赖的core-js吧_第1张图片

他看了看官网的升级文档,这么简单,是时候表演真正的技术了
OSS is not defined? 检查检查你依赖的core-js吧_第2张图片

最后发现提示没有core-js,然后就随手npm i core-js -S了,部署上线,搞定下班回家

第二天凌晨2点

Oh,yeah,今天好运气,老狼请吃鸡,你打电话我不接,你打他有啥用啊~

小李猛然惊醒,这是他为产品专设的铃声,一看时间,马萨卡

接到电话:"线上上传不了图片了,你干啥了,昨天还行,快 快 快,快看看"。
伴随着这奇特的词语,小李光速打开电脑一看
OSS is not defined? 检查检查你依赖的core-js吧_第3张图片

凌晨5点

“我搜遍了全网没人碰到这个问题,OSS is not defined”,
“我不管,上班前必须修好, 滴 滴 滴 ...”

小李开始了每个月总有那么几天的bug修复生活,内心无比抑郁,心情极度暴躁

既然是今天发生的是不是因为升级了@vue/cli,回退版本

老版本可以,小李内心有点小庆幸,知道了原因可能是因为升级脚手架导致的,但是为什么呢?

他开始梳理上传的逻辑,是按照阿里云官方的方法引入了aliyun-upload-sdk-1.5.0.min.jsaliyun-oss-sdk-5.3.1.min.js,这没毛病啊为什么startUploadOSS is not defined啊,WDN...
他开始对比package-lock.jsonpackage.json中的依赖项,我什么时候装了core-js^3.6.5,卸载,纳尼? 服务起不来了,马萨卡,@vue/cli^4依赖了core-js^3.6.5? 果然
OSS is not defined? 检查检查你依赖的core-js吧_第4张图片

这玩意依赖了core-js,降级 吧,为啥@vue/cli4依赖了core-js3呢,为啥阿里云的sdk没有兼容core-js3呢?

打开阿里云 > 文档 > 反馈: 考虑下JS上传SDK兼容下core-js3?

有哪位老铁能给小李一个解释吗?

你可能感兴趣的