安装多个jdk导致eclipse打不开问题解决方案

问题描述

本来使用的是jdk1.8,由于其他原因需要使用jdk1.6,在安装完jdk1.6后打开eclipse就会报错:
Version 1.6.0_43 of the JVM is not suitable for this product.Version:1.7 or greater is required.

安装多个jdk导致eclipse打不开问题解决方案_第1张图片

问题原因:jdk1.6安装完成时,会将java.exe、javaw.exe、javaws.exe放入环境变量Path的对应的某个目录中(win10是在C:\Windows\system32下)。由于Path值顺序的原因,在执行某个命令时(如:java -version),会按顺序搜索目录,如果已经搜索到命令则不会再继续往后搜索。

解决方法

方法1:C盘搜索java.exe,找到对应目录,删除java.exe、javaw.exe、javaws.exe即可(推荐)

安装多个jdk导致eclipse打不开问题解决方案_第2张图片

方法2: 调整Path变量值的顺序,点击上移,调整到靠前位置:

安装多个jdk导致eclipse打不开问题解决方案_第3张图片

以上就是安装多个jdk导致eclipse打不开问题解决方案的详细内容,更多关于多个jdk导致eclipse打不开的资料请关注脚本之家其它相关文章!

你可能感兴趣的