SpringBoot一个非常蛋疼的无法启动的问题解决

今天遇到了一个非常蛋疼的问题,好好的项目,没有任何报错,但是就是启动不了 还抱一个我看不出问题的错误:

 java.lang.NoSuchMethodError: org.springframework.data.repository.config.AnnotationRepositoryConfigurationSource
 java.lang.NoSuchMethodError: org.springframework.util.Assert.notNull

 真尼玛费时间,几乎一下午就在找原因,网上大多数是说,redis 版本过高,或者是测试类的引入重复,但是都测试了,解决不了问题,然后之后自己又探索了半天还是无法解决。
 后来,我点到了报错的方法所在的class类文件后才发现,报错的整体都在spring_boot_framework 里,心想这个或许也和版本不兼容有关吧,于是就换了一个低的版本,果然,换了之后就正常启动了,妈的,真的日了狗了,这框架能不能不要提示的这么隐晦,直接说版本不兼容就好了。下面是修改的地方:

    
  org.springframework.boot
  spring-boot-starter-web
  
  
   org.springframework.boot
   spring-boot-starter-tomcat
  
  
  1.5.8.RELEASE
 
 
  org.springframework.boot
  spring-boot-starter-jetty
  1.5.1.RELEASE
 

任何框架都有弊病,SpringBoot也不例外,这框架要是国人开发的,我想就不会让人这么费解了。希望有朝一日,我们国内的程序员能开发出自己的开源框架。

到此这篇关于SpringBoot一个非常蛋疼的无法启动的问题解决的文章就介绍到这了,更多相关SpringBoot 无法启动内容请搜索脚本之家以前的文章或继续浏览下面的相关文章希望大家以后多多支持脚本之家!

你可能感兴趣的