我要以血和泪的经历告诉你,这个 bug 太难解决了

[npm install报错: npm WARN tar ENOENT: no such file or directory]

`npm install
npm WARN deprecated request@2.88.2: request has been deprecated, see request/request#3142
npm WARN deprecated mkdirp@0.5.1: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
npm WARN deprecated @hapi/joi@16.1.8: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated har-validator@5.1.5: this
npm WARN deprecated @hapi/address@2.1.4: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/pinpoint@1.0.2: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated intl-locales-supported@1.8.12: bad publish
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
npm WARN deprecated core-js@1.2.7: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/res...
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/uri...
npm WARN deprecated @types/vfile-message@2.0.0: This is a stub types definition. vfile-message provides its own type definitions, so you do not need this installed.
npm WARN tarball tarball data for typescript@^3.5.3 (sha1-mNYApevcOPQMsndSLxLcgA6eJfo=) seems to be corrupted. Trying one more time.
npm WARN tar ENOENT: no such file or directory, open 'E:projectstestantnode_modules.stagingpath-browserify-3b0bb9cetesttest-path.js'
npm WARN tar ENOENT: no such file or directory, open 'E:projectstestantnode_modules.staginges-abstract-97c5d0542020SetIntegrityLevel.js'
npm WARN tar ENOENT: no such file or directory, open 'E:projectstestantnode_modules.staginges-abstract-ab25e7a02019ToPropertyDescriptor.js'
npm WARN tar ENOENT: no such file or directory, open 'E:projectstestantnode_modules.stagingparse5-b83ed148libcommondoctype.js'
npm WARN tar ENOENT: no such file or directory, open 'E:projectstestantnode_modules.staginges-abstract-97c5d054helperssetProto.js'
npm WARN tar ENOENT: no such file or directory, open 'E:projectstestantnode_modules.stagingregenerate-unicode-properties-72a824afGeneral_CategoryModifier_Letter.js'
npm WARN tar ENOENT: no such file or directory, open 'E:projectstestantnode_modules.staginges-abstract-ab25e7a05ToPropertyDescriptor.js'
……
……
npm WARN tar ENOENT: no such file or directory, open 'E:projectstestantnode_modules.staging@ant-designicons-svg-18a53a75libasnInboxOutlined.d.ts'
npm WARN tar ENOENT: no such file or directory, open 'E:projectstestantnode_modules.staging@ant-designicons-svg-18a53a75esindex.d.ts'
npm ERR! A complete log of this run can be found in:
npm ERR! C:Usersyangyang43AppDataRoamingnpm-cache_logs2020-08-24T08_54_04_848Z-debug.log
`

其他信息

所有网上的方法,

  • npm cache clean -f
  • 删除 .npmrc
  • 删除 npm-cache
  • 卸载重装 node,
  • 降级 node,npm
  • 换淘宝镜像

统统没用

老天,怎么解决啊

最后还是使用 yarn 命令:

`npm install yarn -g
yarn install
`

你可能感兴趣的