Tomcat启动报错java.lang.UnsatisfiedLinkError

之前tomcat启动老是报错,虽然不影响项目的启动运行,但是有强迫症的程序员会心里不爽:Tomcat启动报错java.lang.UnsatisfiedLinkError_第1张图片

问题是由于本机安装的jdk版本与tomcat中使用的jdk版本不一致导致的。

后面我把原先tomcat启动环境用的jdk1.7改为了本机安装的jdk1.8就不在报错。

具体过程:在myeclipse中点击window→preference→在搜索框中输入Tomcat→选择安装的tomcat版本,我这里是选择Tomcat 7.x→点击JDK→在Tomcat 7.x JDK name:下拉选项中选择在本机中安装的jdk版本→点击OK然后再次启动tomcat就不会报错了。

转载于:https://www.cnblogs.com/zydhh/p/7049628.html

你可能感兴趣的