浅谈pytorch、cuda、python的版本对齐问题

在使用深度学习模型训练的过程中,工具的准备也算是一个良好的开端吧。熟话说完事开头难,磨刀不误砍柴工,先把前期的问题搞通了,能为后期节省不少精力。

以pytorch工具为例:

pytorch版本为1.0.1,自带python版本为3.6.2

服务器上GPU的CUDA_VERSION=9000

注意:由于GPU上的CUDA_VERSION为9000,所以至少要安装cuda版本>=9.0,虽然cuda=7.0~8.0也能跑,但是一开始可能会遇到各种各样的问题,本人cuda版本为10.0,安装cuda的命令为:

conda install cudatoolkit=10.0

注:GPU显卡驱动一般没什么问题,所以尽量不要动cudnn的版本。

以上这篇浅谈pytorch、cuda、python的版本对齐问题就是小编分享给大家的全部内容了,希望能给大家一个参考,也希望大家多多支持脚本之家。

你可能感兴趣的