SpringBoot打成war包在tomcat或wildfly下运行

SpringBoot打包形式

默认情况下,创建的SpringBoot项目是按照jar包形式来进行打包的。同时,内置了tomcat的容器。

那么,此时如果想让springboot打包成war包,并部署到wildfly等容器,该如何处理?

下面将从创建项目开始逐一讲解。

创建项目

创建项目没有什么难点,使用idea工具创建一个简单的maven项目即可,如果你的项目已经是springboot项目,想要修改为war包形式,对照修改即可。

修改pom.xml配置

创建项目之后,修改pom.xml文件,添加parent标签。


    org.springframework.boot
    spring-boot-starter-parent
    2.1.5.RELEASE
    

如果原来是springboot项目,则已经包含了,不用修改。

pom.xml中设置打包方式为war。

war

添加或修改dependency配置,如下:


    
        org.springframework.boot
        spring-boot-starter
    
    
        org.springframework.boot
        spring-boot-starter-web
        
            
                org.springframework.boot
                spring-boot-starter-tomcat
            
        
    
    
        javax.servlet
        servlet-api
        2.5
    
    
        org.springframework.boot
        spring-boot-starter-test
        test
    

其中在spring-boot-starter-web中需要排除tomcat的依赖。同时,添加servlet-api的依赖。注意这里添加的依赖为Servlet2.5。

在build中使用如下插件进行打包。


    
        
            org.apache.maven.plugins
            maven-war-plugin
            2.6
            
               false
            
        
    

启动main方法

如果已经存在启动的main方法,则让main方法继承SpringBootServletInitializer,并实现其方法即可。如果是新创建项目,则直接在顶级目录创建SpringBootApp(启动类),然后启动diam如下。

@SpringBootApplication
public class SpringBootApp extends SpringBootServletInitializer {

	public static void main(String[] args) {
		SpringApplication.run(SpringBootApp.class, args);
	}

	@Override
	protected SpringApplicationBuilder configure(SpringApplicationBuilder builder) {
		return builder.sources(SpringBootApp.class);
	}
}

打包

通过maven命令执行package打包即可,在target目录下即可生成war包。

至于tomcat和wildfly的部署,都可将war包放置于对应的目录下启动服务即可。

异常情况

如果在启动时报如类似如下异常(提示缺少web.xml):

Error assembling WAR: webxml attribute is required (or pre-existing WEB-INF/web.xml if executing in update mode)

注意检查pom文件打包插件和是否排除了tomcat的问题,核查上面的打包插件是否正确。

问题的原因是:springboot项目中引用了依赖包spring-boot-starter-web。该包中引用的spring-boot-starter-tomcat里包含了tomcat嵌入式servlet容器,其不同版本实现的是不同的servlet版本规范。

Servlet/JSP版本2.5/2.1支持Tomcat的版本为6.0.x,最低java版本为1.5。Servlet/JSP版本3.0/2.2支持Tomcat的版本为7.0.x,最低java版本为1.6。

由于上面使用了Servlet2.5,当没有web.xml文件时会出现上面的异常。

解决方式一:当Servlet版本小于3时,使用创建/src/main/webapp/WEB-INF/web.xml文件。

解决方式二:在pom.xml的build下添加maven-war-plugin插件。并设置failOnMissingWebXml为false。

原文链接:《SpringBoot打成war包在tomcat或wildfly下运行》


程序新视界

公众号“程序新视界”,一个让你软实力、硬技术同步提升的平台

SpringBoot打成war包在tomcat或wildfly下运行_第1张图片

你可能感兴趣的