当前位置:首页 > 开发 > 编程语言 > Ruby > 正文

sunspot-rails无法启动,后台访问404错误

发表于: 2015-03-18   作者:hotsunshine   来源:转载   浏览次数:
摘要: 问题是这样的: bundle exec rake sunspot:solr:start RAILS_ENV=production 执行之后日志显示是成功的,但是去做index索引的时候,返回的是错误下面这个错误 引用 Rails app: Solr throwing RSolr::Error::Http - 404 Not Found when executing s
问题是这样的:
bundle exec rake sunspot:solr:start RAILS_ENV=production


执行之后日志显示是成功的,但是去做index索引的时候,返回的是错误下面这个错误
引用
Rails app: Solr throwing RSolr::Error::Http - 404 Not Found when executing search


很显然是没有启动成功,上面那个success只是一个假象而已。

解决方案,在config/sunspot.yml中的配置中添加一项:

solr_home: solr


注意千万别手欠写成xml

参考地址
http://stackoverflow.com/questions/19759906/rails-app-solr-throwing-rsolrerrorhttp-404-not-found-when-executing-searc

sunspot-rails无法启动,后台访问404错误

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
症状: 在Linux下通过命令行直接运行tomcat/bin目录下的startup.sh脚本可以正常启动Tomcat,但是配
eclipse正常启动tomcat,但是 访问http://localhost:8080 却报404错误 修改下配置 就好操作如下图
接着上次写的文章 XP和Win7设置系统自动同步系统时间方法 本文就把故障出现的过程和解决方法一共写
我从官网上面下载的tomcat6,直接启动发现正常使用,但是在Eclipse绑定后启动,访问localhost:8080
我从官网上面下载的tomcat6,直接启动发现正常使用,但是在Eclipse绑定后启动,访问localhost:8080
问题: 1、eclipse中配置好tomcat服务器后,启动tomcat查看控制台信息显示启动成功, 但访问tomcat首
问题: 1、eclipse中配置好tomcat服务器后,启动tomcat查看控制台信息显示启动成功, 但访问tomcat首
问题: 1、eclipse中配置好tomcat服务器后,启动tomcat查看控制台信息显示启动成功, 但访问tomcat首
看图说话有说服力 今天使用eclipse配置了tomcat后通过右键菜单启动后,但是访问其主页确是报错404,
症状: tomcat在eclipse里面能正常启动,而在浏览器中访问http://localhost:8080/不能访问,且报404
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号