当前位置:首页 > 开发 > 编程语言 > 编程 > 正文

The server does not support version 2.5 of the J2EE Web module specification

发表于: 2013-03-25   作者:Bll   来源:转载   浏览:
摘要: 今天用Eclipse部署一个Web项目Test,报如下错误: 原来创建Test时用的是Tomcat 6.0,而现在用的是Tomcat 5.0。jdk都是用的1.5 Tomcat 5.0最多支持Servlet 2.4 解决如下: 在项目根目录下有一个.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.project.facet.core.
今天用Eclipse部署一个Web项目Test,报如下错误:

原来创建Test时用的是Tomcat 6.0,而现在用的是Tomcat 5.0。jdk都是用的1.5

Tomcat 5.0最多支持Servlet 2.4

解决如下:

在项目根目录下有一个.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.project.facet.core.xml文件,内容如下:

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="jst.web"/>
  <fixed facet="wst.jsdt.web"/>
  <fixed facet="java"/>
  <installed facet="java" version="1.5"/>
  <installed facet="jst.web" version="2.5"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>

  把<installed facet="jst.web" version="2.5"/>改为  <installed facet="jst.web" version="2.4"/>




注:
tomcat版本(5.5):支持web程序(2.4);
tomcat版本(6.0):支持web程序(2.5);
tomcat版本(7.0):支持web程序(3.0)

另外:
也可以重新下载更高版本的tomcat~




参考:http://oracleabc-126-com.iteye.com/blog/913946

The server does not support version 2.5 of the J2EE Web module specification

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号