当前位置:首页 > 开发 > 数据库 > 正文

mysql安装出错

发表于: 2015-07-19   作者:林鹤霄   来源:转载   浏览:
摘要: [root@localhost ~]# rpm -ivh MySQL-server-5.5.24-1.linux2.6.x86_64.rpm Preparing...                #####################

[root@localhost ~]# rpm -ivh MySQL-server-5.5.24-1.linux2.6.x86_64.rpm 
Preparing...                ########################################### [100%]
        file /usr/share/mysql/charsets/README from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/Index.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/armscii8.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/ascii.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/cp1250.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/cp1251.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/cp1256.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/cp1257.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/cp850.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/cp852.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/cp866.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/dec8.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/geostd8.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/greek.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/hebrew.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/hp8.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/keybcs2.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/koi8r.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/koi8u.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/latin1.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/latin2.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/latin5.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/latin7.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/macce.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/macroman.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/swe7.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/czech/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/danish/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/dutch/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/english/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/estonian/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/french/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/german/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/greek/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/hungarian/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/italian/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/japanese/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/korean/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/norwegian-ny/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/norwegian/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/polish/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/portuguese/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/romanian/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/russian/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/serbian/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/slovak/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/spanish/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/swedish/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64

        file /usr/share/mysql/ukrainian/errmsg.sys from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64

原因是系统已经安装了其他版本的mysql-libs包导致不兼容。

[root@localhost ~]# yum list | grep mysql                                                                                                                               
mysql-libs.x86_64                    5.1.61-1.el6_2.1          @updates         
apr-util-mysql.x86_64                1.3.9-3.el6_0.1           base             
bacula-director-mysql.x86_64         5.0.0-9.el6               base             
bacula-storage-mysql.x86_64          5.0.0-9.el6               base             
dovecot-mysql.x86_64                 1:2.0.9-2.el6_1.1         base             
freeradius-mysql.x86_64              2.1.10-5.el6              base             
libdbi-dbd-mysql.x86_64              0.8.3-5.1.el6             base             
mod_auth_mysql.x86_64                1:3.0.0-11.el6_0.1        base             
mysql.x86_64                         5.1.61-1.el6_2.1          updates          
mysql-bench.x86_64                   5.1.61-1.el6_2.1          updates          
mysql-connector-java.x86_64          1:5.1.12-2.el6            base             
mysql-connector-odbc.x86_64          5.1.5r1144-7.el6          base             
mysql-devel.i686                     5.1.61-1.el6_2.1          updates          
mysql-devel.x86_64                   5.1.61-1.el6_2.1          updates          
mysql-embedded.i686                  5.1.61-1.el6_2.1          updates          
mysql-embedded.x86_64                5.1.61-1.el6_2.1          updates          
mysql-embedded-devel.i686            5.1.61-1.el6_2.1          updates          
mysql-embedded-devel.x86_64          5.1.61-1.el6_2.1          updates          
mysql-libs.i686                      5.1.61-1.el6_2.1          updates          
mysql-server.x86_64                  5.1.61-1.el6_2.1          updates          
mysql-test.x86_64                    5.1.61-1.el6_2.1          updates          
php-mysql.x86_64                     5.3.3-3.el6_2.8           updates          
qt-mysql.i686                        1:4.6.2-20.el6            base             
qt-mysql.x86_64                      1:4.6.2-20.el6            base             
rsyslog-mysql.x86_64                 4.6.2-12.el6              base            

删除mysql-libs

[root@localhost ~]# yum remove mysql-libs

......

[root@localhost ~]# rpm -ivh MySQL-server-5.5.24-1.linux2.6.x86_64.rpm                                                                                                  
Preparing...                ########################################### [100%]
   1:MySQL-server           ########################################### [100%]

mysql安装出错

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
mysql 安装出错: 1.MYSQL服务无法启动1067解决办法   在运行mysql administrator的时候,无法登录
mysql安装最后一步 无法启动服务错误 博客分类: IDE问题解析 今天安装mysql程序时候,在安装到最后
mysql安装最后一步 无法启动服务错误 博客分类: IDE问题解析 今天安装mysql程序时候,在安装到最后
Windows系统中,如果先前已安装有MySQL,修复或卸载重装后,在最后一步会提示不成功! 可能原因: 1
Windows系统中,如果先前已安装有MySQL,修复或卸载重装后,在最后一步会提示不成功! 可能原因: 1
今天准备移动网站到另外一个服务器,用的是mysql数据库,导出的时候正常,导入的时候出现了一个错误
Windows系统中,如果先前已安装有MySQL,修复或卸载重装后,在最后一步会提示不成功! 可能原因: 1
环境:Ubuntu 注意:非root用户在输入命令时,要在命令前加sudo。 【简单安装】 一般第一次安装Apac
安装cocos2d出错解决办法 首先,cocos2d的下载地址是:www.cocos2d-iphone.org/download,留个做备
今天安装TSVN时刚到一半弹出一个对话框,确定后安装就被中断了,对话框的内容是“Windows Installer
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号