当前位置:首页 > 开发 > 系统架构 > 架构 > 正文

hadoop与eclipse

发表于: 2012-10-17   作者:blackproof   来源:转载   浏览次数:
摘要: 个人笔记:(需要懂点java和用过点eclipse的)   配置完hadoop分布式环境,就要做eclipse开发了   1.配置eclipse的map/reduce比较简单   2.先现在插件,放到eclipse中   3.配置hadoop目录   4.在配置Location   碰到的错误: 1 unknow

个人笔记:(需要懂点java和用过点eclipse的)

 

配置完hadoop分布式环境,就要做eclipse开发了

 

1.配置eclipse的map/reduce比较简单

 

2.先现在插件,放到eclipse中

 

3.配置hadoop目录

 

4.在配置Location

 

碰到的错误:

1 unknown host -- 想必大家都是在window下开发的 需要配置window/system32/driver/host,加入节点的host ip空格host name

 

2 Unsupported major.minor version 51.0 -- 这个老手一看就知道是java version的错误,需要调整jdk版本,一般使用1.6的

hadoop与eclipse

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
经过一段时间的折腾,终于能在eclipse里面运行MR了。 主要是运行eclipse里面运行的用户必须是 hdfs里
这是解压hadoop后,hadoop-1.2.1目录 各目录结构及说明: Eclipse导入Hadoop源码项目: 注意:如果
开篇:Hadoop是一个强大的并行软件开发框架,它可以让任务在分布式集群上并行处理,从而提高执行效
通常我们可以用Eclipse作为Hadoop程序的开发平台。 1) 下载Eclipse 下载地址:http://www.eclipse.
  由于hadoop主要是部署和应用在linux环境中的,但是目前鄙人自知能力有限,还无法完全把工作环境
版本: eclipse:   eclipse-jee-juno-SR2-linux-gtk   tomcat7: apache-tomcat-7.0.39 一,下
hadoop版本为hadoop1.2.1 eclipse版本为eclipse-standard-kepler-SR2-win32-x86_64 WordCount.java
eclipse中hadoop开发 安装hadoop插件。hadoop插件可以从网上下载,也可以自己编译,我用的是1.0.2,
插件 话说Hadoop 1.0.2/src/contrib/eclipse-plugin只有插件的源代码,这里给出一个我打包好的对应
插件 话说Hadoop 1.0.2/src/contrib/eclipse-plugin只有插件的源代码,这里给出一个我打包好的对应
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号