当前位置:首页 > 开发 > 编程语言 > PHP > 正文

PHP框架中的SPB分离

发表于: 2011-05-09   作者:bardo   来源:转载   浏览次数:
摘要:         什么是SPB分离?SPB分离是一种WEB标准。并且是客户端的标准。具体如下                HTML——Structure 结构  &nbs

        什么是SPB分离?SPB分离是一种WEB标准。并且是客户端的标准。具体如下
                HTML——Structure 结构
                CSS——Presentation 表现
                JavaScript——Behavior 行为
        作为服务器端的PHP程序,一般所要求的是数据、算法、表现分离。于是,就有MVC架构模式。按理说,PHP中不存在SPB分离。实际并不是这样的。
        这是因为,你没有使用PHP来写web ui组件。如果要用PHP生成web ui组件,则必须要面对SPB分离这个问题。
        为什么要写web ui组件?组件式开发,其开发速度是最快的。比如,JSP有JSF,还有Tapestry。缺少组件,至今仍是PHP的一大问题。
        但是,如何来写web ui组件?看看目前大量的提供组件的框架,我们不难发现,这些PHP框架提供的web ui组件,不是不易使用,即是扩展性相当差。而且,最大的缺陷还在于,维护困难,并且运行效率低下。
        有人会说,本来,需要你用代码,用HTML+CSS将这些都做好。现在完全由代码自动生成,效率自然就差了。这或许是理由。但实际上,web ui组件开发的技术,或者开发思想决定了PHP框架提供的web ui组件的根本的效率。同时也决定了它的可扩展性,可维护性与易用性。
        那么,PHP框架提供的web ui组件,如何做到这些?这不是单一的设计模式理论能完全解决的。一个根本问题,就是首先要实现SPB分离!
        相对于web ui组件,其结果是SPB分离,那么,程序首先是将结构、表现、行为分开处理。而对于结构,则是基于MVC,其数据来源于模块。生成结构的则是web ui组件的核心代码——算法部分。而这一算法,如果是基于设计模式的,那么,这样的结构才是最佳结构。
        PHP现在没有支持web ui组件IDE。SPB分离则会增加web ui组件的易用性,便于程序对各部分独立操作。当然,将来如果有支持web ui组件IDE,直接在IDE中设计,一样也是相当的方便。因为,SPB分离为设计时显示能够提供统一的调用接口。而现在的PHP框架提供的web ui组件,均是做不到的。
        经过SPB分离以后,代码与算法将会变得更加精简。如果你按此理念动手编写,肯定会发现这一点,精简的算法,其运行效率肯定会大幅度提高。这是必然的。
        由此,我们可以总结出一点:那就是,我们应当面向数据结构,而不是面向原始数据。正如笔者《人民币金额数字转中文大写程序多种编程语言汇总2011版》一文中所说,我们需要对数据进行预处理,使得它能成为程序易于处理的数据结构。

PHP框架中的SPB分离

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
随意混用 PHP 与其他 Web 页面标记将导致程序逻辑、HTML、层叠样式表(Cascading Style Sheets,CSS
使用智能模板引擎分离 Web 页面标记与底层设计逻辑 文档选项 将此页作为电子邮件发送 未显示需要 Ja
用 Smarty 分离 PHP 应用程序中的形式与功能 使用智能模板引擎分离 Web 页面标记与底层设计逻辑 文
   现在在一家公司做PHP后台开发程序猿(我们组没有前端,做活动时会做前端的东西),刚开始到公
1.代码结构的划分: 目前的目录结构: /站点根目录 /application/应用程序目录 Model/模型目录 Vie
注意: win/linux都支持正斜线,而Linux不支持反斜线,故所有目录用正斜线 配置文件,数据库类等文
CSS 中的分离、抽象和层叠 转自: http://www.html5cn.org/article-4503-1.html#508534-baidu-1-4074
PHP成为世界上最流行的脚本语言有许多原因:灵活性,易用性等等。但通常只用PHP或者其他语言编码就
Zend Framework ThinkPHP CodeIgniter Yii Framework 1、CodeIgniter CodeIgniter 是一个应用开发框
下载框架 到官网http://kohanaframework.org/下载,我用的是3.2。。。3.3的框架要求要php5.3以上 配
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号