当前位置:首页 > 开发 > 研发管理 > 正文

解决:Project facet Java version 1.7 is not supported.

发表于: 2014-04-08   作者:AILIKES   来源:转载   浏览次数:
摘要: 在移植eclipse项目时,如果遇到 “Project facet Java version 1.7 is not supported.”   项目中的jdk1.7不支持。说明项目是其他版本jdk编译的,在eclipse里运行时会报版本不支持。 解决办法: 法1,选中项目 Properties , 选择 Project Facets,右击选择&nb

在移植eclipse项目时,如果遇到

“Project facet Java version 1.7 is not supported.”

 

项目中的jdk1.7不支持。说明项目是其他版本jdk编译的,在eclipse里运行时会报版本不支持。

解决办法:

1,选中项目 Properties , 选择 Project Facets,右击选择 Java , Change Version ...          即可。

2,在 项目的目录下有一个.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.project.facet.core.xml文件,内容如下;

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
<fixed facet="jst.java"/>
<fixed facet="jst.web"/>
<installed facet="jst.web" version="2.4"/>
<installed facet="jst.java" version="6.0"/>
</faceted-project>

修改 <installed facet="jst.java" version="6.0"/>  <installed facet="jst.java" version="5.0"/> 即可。

解决:Project facet Java version 1.7 is not supported.

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
当运行这个web程序时,无法运行,提示错误如下: 当时安装的tomcat是tomcat7版本,安装的jdk版本是1
1.当你在运行web时候,添加web应用,提示没找到应用,本来有可以启动的或者新建的web应用,但是启动
问题描述 在eclipse中,从SVN中检出project代码,拖拽式部署到local server中的时候,报出以下错误
java项目中,若切换服务器,经常会涉及到动态web模块版本的问题。 比如:新建了web项目,开始使用to
java项目中,若切换服务器,经常会涉及到动态web模块版本的问题。 比如:新建了web项目,开始使用to
我们用Eclipse创建Maven结构的web项目的时候选择了Artifact Id为maven-artchetype-webapp,由于这个
今天将MyEclipse升级到 9.1 后,打开原来的工作空间,原来所有的项目都前面都显示了一个小叉叉,代码
项目出现 java compiler level does not match the version of the installed java project facet
参考这篇博文 http://www.cnblogs.com/lemonme/articles/1655894.html 这个是因为Facted Project 中
我们用Eclipse创建Maven结构的web项目的时候选择了Artifact Id为maven-artchetype-webapp,由于这个
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号