当前位置:首页 > 开发 > 移动开发 > 正文

Android中error inflating class fragment

发表于: 2013-06-19   作者:矮蛋蛋   来源:转载   浏览:
摘要: 原文地址: http://blog.csdn.net/qp120291570/article/details/8451620 在Activity中静态使用fragment的时候,要注意两个地方。 Fragment引用的包是: import android.support.v4.app.Fragment; 而不是: import android.app.Fragment; 然后Ac
原文地址: http://blog.csdn.net/qp120291570/article/details/8451620
在Activity中静态使用fragment的时候,要注意两个地方。
Fragment引用的包是:
import android.support.v4.app.Fragment;
而不是:
import android.app.Fragment;

然后Activity必须是继承FragmentActivity
import android.support.v4.app.FragmentActivity;

不然就会出现这个错误。

Android中error inflating class fragment

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号