当前位置:首页 > 开发 > 编程语言 > Eclipse > 正文

maven integration for eclipse jdk warning

发表于: 2013-11-19   作者:a1129963143   来源:转载   浏览:
摘要: 在Eclipse中安装m2eclipse插件后,启动Eclipse出现警告。 警告的标题是: maven integration for eclipse jdk warning; 我的解决办法是在Eclipse程序文件(安装文件)处有一个eclipse.ini文件,打开后如下 引用     -startup plugins/or
在Eclipse中安装m2eclipse插件后,启动Eclipse出现警告。

警告的标题是:
  maven integration for eclipse jdk warning;


我的解决办法是在Eclipse程序文件(安装文件)处有一个eclipse.ini文件,打开后如下

引用

    -startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120913-144807
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile

-vmargs
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-Xms40m
-Xmx512m



修改后如下

引用

  -startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120913-144807
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
D:\File\java\jdk17017\bin
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-Xms40m
-Xmx512m



主要是在其中添加了两句:
引用

   -vm
D:\File\java\jdk17017\bin


这两句必须在-vmargs前面,否则无效。

maven integration for eclipse jdk warning

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
myeclipse6.5 安装maven后,启动报warning。。。。 解决方式: 添加 -vm D:\Program Files\Java\jdk1
若在Eclipse启动时,出现上图中的情况解决方法: 1:打开eclipse Click on ‘Window’ -> ‘Pref
【国外转】Spring Android and Maven (Maven Integration for Eclipse插件和Maven Integration for
Ant > Ant Eclipse IDE Integration Ant Eclipse IDE Integration To integrate Ant build file
启动的时候会提示,maven是运行在jdk下的,但是你的Eclipse是用的jre,所以maven有些功能会用不了。
无数次的安装java开发环境,每次都是上网看配置,今天单位给配新本本,自己也总结一下环境搭建的过
安装Maven后每次启动出现警告信息: Eclipse is running in a JRE, but a JDK is required Some Mave
Eclipse添加maven之后报错 Eclipse is running in a JRE, but a JDK is required 解决方法 安装Mave
安装Maven后每次启动出现警告信息: Eclipse is running in a JRE, but a JDK is required Some Mave
安装Maven后每次启动出现警告信息: Eclipse is running in a JRE, but a JDK is required Some Mave
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号