当前位置:首页 > 开发 > 编程语言 > Java > 正文

Java项目@override报错的解决方法

发表于: 2015-01-14   作者:JokerLinisty   来源:转载   浏览:
摘要:   1、错误原因:JDK1.5版本不支持在对接口的实现时使用@override注解。     2、说明:JDK1.6版本修复以上BUG,即子类在对父类方法覆盖以及对接口的实现都支持@override注解。     3、解决方法:将MyEclipse(以及项目)的JDK版本修改为1.6即可。     1)、选

  1、错误原因:JDK1.5版本不支持在对接口的实现时使用@override注解。

 

  2、说明:JDK1.6版本修复以上BUG,即子类在对父类方法覆盖以及对接口的实现都支持@override注解。

 

  3、解决方法:将MyEclipse(以及项目)的JDK版本修改为1.6即可。

 

  1)、选择eclipse菜单Windows->Preferences-->java->Compiler-->compiler compliance level选择 1.6,刷新工程,重新编译。

  2)、右键项目,依次选择 Properties-->Java Compiler-->compiler compliance level 中选择 1.6,刷新工程,重新编译。

 

 

Java项目@override报错的解决方法

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号