当前位置:首页 > 开发 > 编程语言 > 编程 > 正文

路由器基本配置命令

发表于: 2007-03-16   作者:cutezjun   来源:转载   浏览:
摘要: 【来  源】:http://www.cublog.cn/u/4110/showart.php?id=256019                       &

【来  源】:http://www.cublog.cn/u/4110/showart.php?id=256019
                                                            路由器基本配置命令(搜集整理)

       一、

  1.router(config)#router rip 启动rip进程
  2.router(conifg-router)#network 172.17.0.0指定rip协议的主网络
  3.router(config-router)#passive-interface f0/1把f0/1配置成passive端口
  4.router(config-router)#neighbor 172.17.12.67 以单波方式通告rip更新给路由器
  5.router(config-if)#ip address 192.168.83.244 255.255.255.0 主ip地址
   router(config-if)#ip address 10.33.55.1 255.255.255.0 secondary辅助ip地址

  二、

  1.router(config-router)#version 2将rip配置成版本2
  2.router(config-ip)#ip rip send version 1只发rip 1数据包
   router(config-ip)#ip rip receive version 2只接收rip 2数据包
  3.router(config-router)#no auto-summary 关闭汇总功能
  4.router(config-if)#no ip split-horizon关闭水平分割
  5.router#show ip ospf database router 192.168.30.10显示路由器LSA通告
   router#show ip ospf database network 192.168.17.18显示网络LSA通告
   router#show ip ospf database summary 172.16.121.0显示网络汇总LSA通告
   router#show ip ospf database asbr-summary显示ASBR汇总LSA通告
   router#show ip ospf database external 10.83.10.0显示自主系统外部LSA通告
   router#show ip ospf database nssa-external显示NSSA外部LSA通告

  三、

  1.router(config)#router ospf 10配置ospf进程id
  2.router(config)#interface loopback0
   router(config-if)#ip address 192.168.10.1 255.255.255.0配置loopback0接口
  3.router(config-router)#area 1 stub 配置stub区域
  4.router(config-router)#area 1 stub no-summary配置totally stubby区域
  5.router(config-router)#area 1 nssa配置nssa区域
  6.router(config-router)#area 25 range 172.16.0.0 255.240.0.0 配置地址汇总
  7.router(config-router)#area 100 virtual-link 192.168.100.33 配置虚链路

  四、

  1.router(config)#standby 172 ip 172.16.10.254加入备份组172 指定虚拟IP 地址
  2.router(config-if)#standby 47 priority 150配置HSRP的优先级150
  3.router(config-if)#standby 47 preempt 配置HSRP的占先权
  4.router(config-if)#standby 47 ip time 2 9  2表示HELLO时间,9表示保持时间
  5.router(config)#interface s0
  6.router(config-if)#standby 47 track s0 100配置跟踪端口s0并在端口down时减少100
  7.router#show standby brief 查看HSRP的状态
  8.router#no debuge all关闭调试功能

  五、

  1.router(config-if)#ip access-group 1 in 访问列表的入
   router(config-if)#ip access-group 1 out访问列表的出
  2.router(config)#access-list 1 premit 192.168.10.0 0.0.0.255 允许192.168.10.0的网段通过
   router(config)#access-list 1 deny 192.168.10.0 2.0.0.255 拒绝192.168.10.2的主机通过
  3.router(config)#access-list 1 premit any ;any表示0.0.0.0 255.255.255.255
   router(config)#access-list 1 premit host 172.30.16.29 ;host表示0.0.0.0
  4.router(config)#access-list 101 deny tcp 172.16.4.0 0.0.0.255 172.16.3.0 0.0.0.255 eq 21拒绝来自172.16.4.0去往172.16.3.0的FTP流量
  5.router(config)#ip access-list extended cisco创建名为cisco的命名访问控制列表

  六、静态地址转换

  1.配置外部端口的IP地址
   Router(config)#interface s0
   Router(config-if)#ip address 61.159.62.129 255.255.255.248
  2.配置内部端口的IP地址
   Router(config)#interface e0
   Router(config-if)#ip address 192.168.100.1 255.255.255.0
  3.静态地址转换
   Router(config)#ip nat inside source static 192.168.100.2 61.159.62.130
  4.在内部和外部端口上启用NAT
   Router(config)#interafce s0
   Router(config-if)#ip nat outside
   Router(config)#interafce e0
   Router(config-if)#ip nat inside

  七、动态NAT配置

  1.配置外部端口的IP地址
   Router(config)#interface s0
   Router(config-if)#ip address 61.159.62.129 255.255.255.248
  2.配置内部端口的IP地址
   Router(config)#interface e0
   Router(config-if)#ip address 192.168.100.1 255.255.255.0
  3.定义内部网络允许访问外部网络
   Router(config)#access-list 1 permit 192.168.100.0 0.0.0.255
  4.定义合法的IP地址池
   Router(config)#ip nat pool chen 61.159.62.129 61.159.62.190 netmask  255.255.255.248
  5.实现网络地址转换
   Router(config)#ip nat inside source list 1 pool chen
  6.在内部和外部端口上启用NAT
   Router(config)#interafce s0
   Router(config-if)#ip nat outside
   Router(config)#interafce e0
   Router(config-if)#ip nat inside

  八、PAT的配置

  1.配置外部端口的IP地址
   Router(config)#interface s0
   Router(config-if)#ip address 61.159.62.129 255.255.255.248
  2.配置内部端口的IP地址
   Router(config)#interface e0
   Router(config-if)#ip address 192.168.100.1 255.255.255.0
  3.定义内部网络允许访问外部网络
   Router(config)#access-list 1 permit 192.168.100.0 0.0.0.255
  4.定义合法的IP地址池
   Router(config)#ip nat pool chen 61.159.62.129 61.159.62.190 netmask  255.255.255.248
  5.实现复用IP地址转换
   Router(config)#ip nat inside source list 1 pool chen overload
  6.在内部和外部端口上启用NAT
   Router(config)#interafce s0
   Router(config-if)#ip nat outside
   Router(config)#interafce e0
   Router(config-if)#ip nat inside

路由器基本配置命令

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号