当前位置:首页 > 开发 > Web前端 > 前端 > 正文

JFreeeChat Unable to validate using XSD

发表于: 2010-07-16   作者:cuisuqiang   来源:转载   浏览:
摘要: 根据资料总结可能是由如下原因引起: 1:少包 ­­­相关认为是缺少 xml-apis.jar 和 xercesImpl.jar 两个包,经验证,不是该错!2:版本问题 按错误提示中说的“Are you running on Java 1.4 or below with Apache Crimson? Upgrade to Apache Xerces (or Java

根据资料总结可能是由如下原因引起:

1:少包

­­­相关认为是缺少 xml-apis.jarxercesImpl.jar 两个包,经验证,不是该错!
2:版本问题

按错误提示中说的“Are you running on Java 1.4 or below with Apache Crimson? Upgrade to Apache Xerces (or Java 1.5) for full XSD support”,则可能是JDK版本问题,排除,Myeclipse和Tomcat配置的都是1.6最高版本

最终确定是包冲突

Your JAXP provider [gnu.xml.dom.JAXPFactory@5e7663] does not support XML Schema,JFreeeChat里有个包引起的冲突gunjaxp.jar,删掉后测试成功!

注意在SSH里使用JFreeeChat时注意!

JFreeeChat Unable to validate using XSD

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号