当前位置:首页 > 开发 > 编程语言 > Ruby > 正文

[ ]Installing qtbindings (alt Qt-Ruby) on Ubuntu

发表于: 2011-12-29   作者:genius_45   来源:转载   浏览:
摘要: 1. Requirements Qt 4.6.x cmake 2.6.3+ gcc 4.x Ruby 2. Install qtbindings. $ gem install qtbindings 2 Building native extensions. This could take a while... 3 Successfully installed qt
1. Requirements
Qt 4.6.x
cmake 2.6.3+
gcc 4.x
Ruby

2. Install qtbindings.
$ gem install qtbindings
2
Building native extensions.  This could take a while...
3
Successfully installed qtbindings-4.6.3.2
4
1 gem installed
5
Installing ri documentation for qtbindings-4.6.3.2...
6
Installing RDoc documentation for qtbindings-4.6.3.2...


3. Test.
01
$ irb
02
ruby-1.9.2-p180 :001 > require 'Qt'
03
 => true
04
ruby-1.9.2-p180 :002 > a = Qt::Application.new(ARGV)
05
 => #<qt::application:0x88743dc objectname="irb">
06
ruby-1.9.2-p180 :003 > button = Qt::PushButton.new('Hello World!',nil)
07
 => #<qt::pushbutton:0x8a04db4 objectname="" ,="" x="0," y="0," width="640," height="480">
08
ruby-1.9.2-p180 :004 > button.resize(300,30)
09
 => nil
10
ruby-1.9.2-p180 :005 > button.show()
11
 => nil
12
ruby-1.9.2-p180 :006 > a.exec()
13
</qt::pushbutton:0x8a04db4></qt::application:0x88743dc>




5. Resouces.
RubyGems.org: http://rubygems.org/gems/qtbindings
QtBindings Homepage: https://github.com/ryanmelt/qtbindings
Qt Homepage: http://qt.nokia.com/

[ ]Installing qtbindings (alt Qt-Ruby) on Ubuntu

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号