当前位置:首页 > 开发 > 编程语言 > 编程 > 正文

Could not find rake-0.9.2 in any of the sources Run `bundle install` to install

发表于: 2011-10-25   作者:genius_45   来源:转载   浏览:
摘要: 刚使用rake test进行测试报错 Could not find rake-0.9.2 in any of the sources Run `bundle install` to install missing gems. 使用sudo bundle install 返回: Fetching source index for http://rubygems.org/ Inst
刚使用rake test进行测试报错
Could not find rake-0.9.2 in any of the sources
Run `bundle install` to install missing gems.

使用sudo bundle install
返回:
Fetching source index for http://rubygems.org/
Installing rake (0.9.2) 
Using multi_json (1.0.3) 
Using activesupport (3.1.1) 
Using builder (3.0.0) 
Using i18n (0.6.0) 
Using activemodel (3.1.1) 
Using erubis (2.7.0) 
Installing rack (1.3.4) 
Using rack-cache (1.1) 
Using rack-mount (0.8.3) 
Using rack-test (0.6.1) 
Using hike (1.2.1) 
Using tilt (1.3.3) 
Installing sprockets (2.0.2) 
Using actionpack (3.1.1) 
Installing mime-types (1.16) 
Using polyglot (0.3.2) 
Using treetop (1.4.10) 
Using mail (2.3.0) 
Using actionmailer (3.1.1) 
Using arel (2.2.1) 
Using tzinfo (0.3.30) 
Using activerecord (3.1.1) 
Using activeresource (3.1.1) 
Using bundler (1.0.21) 
Installing coffee-script-source (1.1.2) 
Installing execjs (1.2.9) 
Installing coffee-script (2.2.0) 
Using rack-ssl (1.3.2) 
Using json (1.6.1) 
Installing rdoc (3.10) 
Using thor (0.14.6) 
Using railties (3.1.1) 
Installing coffee-rails (3.1.1) 
Installing jquery-rails (1.0.14) 
Installing libv8 (3.3.10.2) 
Using rails (3.1.1) 
Installing sass (3.1.10) 
Installing sass-rails (3.1.4) 
Installing sqlite3 (1.3.4) with native extensions 
Installing therubyracer (0.9.8) with native extensions 
Installing uglifier (1.0.3) 

再次调用rake test:
rake aborted!
You have already activated rake 0.9.2.2, but your Gemfile requires rake 0.9.2. Using bundle exec may solve this.

解决:
在Gemfile文件 加入
gem 'rake', '0.9.2.2'

再执行:
sudo bundle update rake


done...





Could not find rake-0.9.2 in any of the sources Run `bundle install` to install

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号