当前位置:首页 > 开发 > 操作系统 > 正文

ubuntu, eclipse indigo subclipse JavaHL版本错误

发表于: 2012-01-03   作者:cncomkyle   来源:转载   浏览:
摘要: 本来已经顺利安装好了subclipse在ubuntu 的eclipse indigo,但是从svn库中拉代码的时候,eclipse报出JavaHL依赖错误,查了subclipse的官网:<<http://subclipse.tigris.org/wiki/JavaHL>>,其给出了两种方案,我先使用了libsvn-java,但是最后eclipse还是报出javaHL版本低的

本来已经顺利安装好了subclipse在ubuntu 的eclipse indigo,但是从svn库中拉代码的时候,eclipse报出JavaHL依赖错误,查了subclipse的官网:<<http://subclipse.tigris.org/wiki/JavaHL>>,其给出了两种方案,我先使用了libsvn-java,但是最后eclipse还是报出javaHL版本低的错误,再试另外一种方案

#sudo su

#cd /opt/apps

#apt-get install alien

#alien  -i CollabNetSubversion-client-1.7.2-1.i386.rpm

#cd /opt/apps/eclipse

打开eclipse.ini 文件,添加以下内容到文件末尾

#gedit eclipse.ini

-Djava.library.path=/opt/CollabNet_Subversion/lib

#./eclipse –clean

可以了。

给安装subclipse时遇到javaHL的同学做个参考

 

ubuntu, eclipse indigo subclipse JavaHL版本错误

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号