当前位置:首页 > 开发 > 操作系统 > 正文

Linux安装flashplayer,让firefox和chrome支持flash

发表于: 2013-12-05   作者:cleans   来源:转载   浏览次数:
摘要:   环境: debian7 x86_64, kde4, 浏览器为chromium和Iceweasel.   描述:chromium即为chrome的原始版本,安装这个相当于已经安装了chrome,Iceweasel为Firefx 17的衍生版本,安装了这个相当于已经安装了Firefox 17。   问题: 安装完浏览器后打开相关的网站无法加载flash &

 

环境: debian7 x86_64, kde4, 浏览器为chromium和Iceweasel.

 

描述:chromium即为chrome的原始版本,安装这个相当于已经安装了chrome,Iceweasel为Firefx 17的衍生版本,安装了这个相当于已经安装了Firefox 17。

 

问题: 安装完浏览器后打开相关的网站无法加载flash

 

解决方法

1.到adobe官网http://get.adobe.com/flashplayer/下载相应这安装包,在这个页面有提示你的系统是什么,比如我用的是chromium去下载,提示就是“Your system:Linux 64-bit, English, Chrome”,这里选择“.tar.gz for other Linux”。然后点击右边的“Download now”按钮,即可自动下载。

 

2.下载得到一个包,如我下载得到的包名为“install_flash_player_11_linux.x86_64.tar.gz”。解压该文件,得到一个名为”usr“的文件夹;另有一个readme.txt文件;还有就是libflashplayer.so文件,这个文件用于复制到浏览器的库类插件文件夹。

 

3.开始安装:

(1)把usr文件夹直接复制到系统根目录下,如果有提示要覆盖,就点确认,但如果是在termianal里并sudo到root的话,那是没有提示的;

(2)把libflashplayer.so分别复制到/usr/lib/chromium/plugins/ 和 /usr/lib/mozilla/plugins/ 文件夹, 前者是chrome的扩展库文件夹,后者是Firefxo的。

(3)为避免意外的权限问题,执行一下面这两条命令:

        chmod 755 /usr/lib/chromium/plugins/libflashplayer.so

        chmod 755 /usr/lib/mozilla/plugins/libflashplayer.so 

 

4.全部关闭chromium和Iceweasel, 再重新打开试试看吧

   

 

Linux安装flashplayer,让firefox和chrome支持flash

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
下载插件 解压插件 使用命令tar -zxvf install_xxxxxx libflashplayer.so 拷贝目录 然后把切换到roo
下载插件 解压插件 使用命令tar -zxvf install_xxxxxx libflashplayer.so 拷贝目录 然后把切换到roo
<html xmlns="http://www.w3.org/1999/xhtml"> <head> <meta http-equiv="Content-T
对于 Adobe 来说,这两天应该是挺不开心的。先是 Facebook 的首席安全官 Alex Stamos 在 Twitter 上
原文地址:http://blog.sina.com.cn/s/blog_6c9da636010103va.html pagespeed 让你的网站页面打开速
打开浏览器,输入adobe flashplayer 进入官方网站,下载Linux 32-bit, 简体中文, Firefox,下载.tar
1. 打开yast2需要管理员口令,如下图 2. 输入口令口后,在yast2 control Center 中选择 software ma
网上有很多类似的webDesktop,但对ie6不支持,所以自己做了一个。 webDesktop for jquery 支持IE6+
网上有很多类似的webDesktop,但对ie6不支持,所以自己做了一个。 webDesktop for jquery 支持IE6+
话不多说,直接上demo,你可以点击下面的图片看效果。 插件代码 (function(){ var fullScreenApi =
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号