当前位置:首页 > 开发 > 编程语言 > Ruby > 正文

ruby学习之环境安装

发表于: 2010-06-01   作者:酷的飞上天空   来源:转载   浏览:
摘要: 看着ruby的渐渐流行,越来越感觉到有必要学习下了。 经过再三考虑决定在Linux下面进行ruby的学习,Linux为Ubuntu9.10,安装在虚拟机中。     首先当然是运行环境的安装,因为只是学习ruby语言,所以并没有涉及到rails的安装。 官方网址为http://www.ruby-lang.org/en/downloads/ 根据官方网址介绍,在li

看着ruby的渐渐流行,越来越感觉到有必要学习下了。

经过再三考虑决定在Linux下面进行ruby的学习,Linux为Ubuntu9.10,安装在虚拟机中。

 

 

首先当然是运行环境的安装,因为只是学习ruby语言,所以并没有涉及到rails的安装。

官方网址为http://www.ruby-lang.org/en/downloads/

根据官方网址介绍,在linux下安装ruby也是很简单的一件事

只需在终端中输入
% sudo apt-get install ruby1.9.1-full 即可安装当前的ruby1.9.1版
也可以
% sudo apt-get install ruby-full 这是安装ruby1.8的版本

 

这里介绍源码安装,也即我使用的安装方法

步骤如下


下载 Ruby Source Code下面的
ruby 1.9.1-p376 大小为8.7M
将文件解压缩,可能之前需要更改下文件属性比如:chmod 770 ruby-1.9.1-p376.tar.gz
为了避免麻烦可以切换到root用户进行安装
tar -zxf ruby-1.9.1-p376.tar.gz
然后进入到解压好的目录
cd ruby-1.9.1-p376
./configure -prefix=/usr/local/ruby   这里我安装到/usr/local/ruby  这个目录
make
make install
下面是添加ruby到操作系统的PATH路径
这里我直接修改的是/etc/enviroment文件,在PATH路径中添加/usr/local/ruby/bin
重启机器使配置生效

然后查看PATH
echo $PATH 看是否添加成功
或者输入
ruby -v
如果显示 ruby 1.9.1p376 (2009-12-07 revision 26041)[i686-linux]则表示ruby运行环境配置完成

 

下面进行我的第一个ruby练习
在终端输入
ruby -e 'puts "hello world!"' 
看到输出的hello world!,表明第一个例子完成了。与java的hello world相比确实简洁了不少。

最后再说一句,如果能像java一样有linux版的安装包就好了

 

我的操作系统是win7,虚拟机为VirtualBox,内存3G。

 

关于使用gem list 提示缺少zlib包的解决方法

1.到zlib官方网站下载zlib的tar包 然后安装

2.进入到ruby的源码包的ext/zlib目录,安装ruby-zlib。直接运行ruby extconf.rb 然后就 make && make install

 

ruby学习之环境安装

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
出现问题: C:\Users\len>gem install rails ERROR: While executing gem ... (Gem::RemoteFetch
出现问题: C:\Users\len>gem install rails ERROR: While executing gem ... (Gem::RemoteFetch
出现问题: C:\Users\len>gem install rails ERROR: While executing gem ... (Gem::RemoteFetch
步骤0 - 安装系统需要的包   For Mac   先安装 [Xcode开发工具,它将帮你安装好 Unix 环境需要
Ruby学习札记(8)-安装InstantRails集成开发环境 用Ruby on Rails(后简称Rails)作Web开发,有个集
本文章为菲利克斯猫(Felix.mao) 原创,转载务必在明显处注明: 原文链接:http://blog.csdn.net/maoju
安装CocoaPots的顺序: Xcode->homebrew->RVM->Ruby->CocoaPats; 1.xcode Xcode就不用
如果你的电脑上没有安装Ruby,还等什么,我们去官方网站下载安装程序吧。对于运行Rails3.0,最低需
http://blog.csdn.net/abbuggy/article/details/7400848 如果你的电脑上没有安装Ruby,还等什么,我
由EasyIOS引出的一系列问题:转载的上一篇CocoaPods安装和使用教程中说明了,为什么要使用cocoapods
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号