当前位置:首页 > 开发 > 系统架构 > 架构 > 正文

dynamic web module和对应的TOMCAT 版本

发表于: 2015-06-20   作者:1259988502   来源:转载   浏览:
摘要: dynamic web module和对应的TOMCAT 版本 用eclipse 创建java web项目时总会出问题  后来发现在创建时 选择dynamic web module 为2.5时才正常 后来发现是因为此处选择与自己的tomcat 有关系 大致因为java的web系统有多种类型,比如静态的和动态的,然后动态的java web project要设置dyna
dynamic web module和对应的TOMCAT 版本

用eclipse 创建java web项目时总会出问题  后来发现在创建时 选择dynamic web module 为2.5时才正常

后来发现是因为此处选择与自己的tomcat 有关系


大致因为java的web系统有多种类型,比如静态的和动态的,然后动态的java web project要设置dynamic web module,也就是动态网页模型,他必须要喝对应的服务器搭配好了才能跑,今天看见的问题就是
dynamic web module 2.4  对应Tomcat 5.5
dynamic web module 2.5  对应Tomcat 6.0
dynamic web module 3.0 对应Tomcat 7.0
更高版本的dynamic web module对与解析更高版本的js有着更高的效率或者是神秘的地方,貌似T7的安全性更高一点,然后Dynamic Web Module 3.0不支持jboss了,没用过jboss,等用到了在看看,补充几点。

补充几个:
Tomcat version 5.5 only supports J2EE 1.2, 1.3, 1.4 Web modules
Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules

要修改此参数只要选中project 点击右键,点击properties点击project facts,在里面勾选或者点击dropdown list去选择version就可以了,至于tomcat只要去阿帕奇的官网下载最新的就可以了,现在的eclipse只有4.0以上的版本,也就是juno版本才支持Dynamic Web Module 3.0的,4.0一下的,连最常用的galileo也只能支持2.5.
更新换代太快了,新(版本)的技术必然伴随着旧的老的(版本)技术的衰退和不兼容,所以现在遇到最多的问题貌似都是在兼容性上,而不是代码的问题了。以后拿到代码之后第一要务就是检查所有包运行环境和服务器等等的相互兼容性了,第二件事才是去做开发了。。。

感谢
http://blog.sina.com.cn/s/blog_529aacbd01014cc8.html

dynamic web module和对应的TOMCAT 版本

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

推荐文章
编辑推荐
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号