当前位置:首页 > 开发 > 系统架构 > 架构 > 正文

Spring 5.0 的系统需求,期待你的反馈

发表于: 2015-06-11   作者:wiselyman   来源:转载   浏览:
摘要:                Spring 5.0将在2016年发布。Spring5.0将支持JDK 9。          Spring 5.0的特性计划还在工作中,请保持关注,所以作者希望从使用者得到关于Spring 5.0系统需求方面的反馈。  

       

       Spring 5.0将在2016年发布。Spring5.0将支持JDK 9。

 

       Spring 5.0的特性计划还在工作中,请保持关注,所以作者希望从使用者得到关于Spring 5.0系统需求方面的反馈。

 

Spring 5.0系统需求:

 

1.Spring 5.0 肯定要将JDK最低限制为JDK 8

       将JDK限制为8+会让Spring框架的代码库更干净,而且我们的核心抽象类、接口都将依赖于JDK 8的API。

 

2.Spring 5.0 将温和的升级Java EE版本

1.Spring 5.0 框架肯定要将Servlet支持提升到Servlet 3.0+;

2.Spring 5.0 将保持JMS1.1+的兼容性,并将支持JMS 2.0;

3.Spring 5.0 将升级到JPA 2.1+ 和Bean Validation 1.1+。

 

3 .注意

      如果你只能使用JDK 6或者7,页没有关系,Spring 将在明年推出4.3版本,和当前的Spring 4.x的系统需求是一样的。

 

4.原文及反馈地址

http://spring.io/blog/2015/06/10/feedback-welcome-spring-5-system-requirements

 

Spring 5.0 的系统需求,期待你的反馈

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
当你在开展一个新的项目,特别是当你在接手另外一个产品的开发的时候,往往我们都倾向于先去对所有
几个例子 你会提反馈吗?不急回答,我们先来看几个例子。 例子一: 项目经理:“xxx,我本来对你的期
你应该以一个什么样的态度处理别人的反馈? Written by Allen Lee 0. 写在前面的话 人不可能完全独
(作者:徐诚 http://blog.csdn.net/shizhebsys保留版权) 2.1.1 硬件需求 目前,Moblin只支持英特
(作者:徐诚 http://blog.csdn.net/shizhebsys保留版权) 2.1.1 硬件需求 目前,Moblin只支持英特
这半个月来,考试系统一直在搞需求.在这个过程中让我深刻的体会到了,搞好需求是我们做好系统的前提.
 项目概述: 该项目为一个基础成绩查询系统,用于廊坊市各类职称考试人员查询成绩,同时后台动
中国程序员技术联盟--交流互助携手并进,期待你的加盟 引言 “直到现在,我还是经常问自己,我到底
中国程序员技术联盟--交流互助携手并进,期待你的加盟 引言 “直到现在,我还是经常问自己,我到底
推送服务对于广大开发者,尤其是Android开发者和运营而言,是必须要用到的一项服务。 如果有一个第
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号