当前位置:首页 > 开发 > 互联网 > 正文

the HTTP rewrite module requires the PCRE library

发表于: 2015-07-19   作者:流浪鱼   来源:转载   浏览:
摘要: ./configure: error: the HTTP rewrite module requires the PCRE library. 模块依赖性Nginx需要依赖下面3个包 1. gzip 模块需要 zlib 库 ( 下载: http://www.zlib.net/ ) 2. rewrite 模块需要 pcre 库 ( 下载: http://www.pcre.org/ ) 3. s

./configure: error: the HTTP rewrite module requires the PCRE library.

模块依赖性Nginx需要依赖下面3个包

1. gzip 模块需要 zlib 库 ( 下载: http://www.zlib.net/ )

2. rewrite 模块需要 pcre 库 ( 下载: http://www.pcre.org/ )

3. ssl 功能需要 openssl 库 ( 下载: http://www.openssl.org/ )

 

Nginx包下载: http://nginx.org/en/download.html

 

依赖包安装顺序依次为:openssl、zlib、pcre, 然后安装Nginx包.

使用在线安装

yum -y install pcre-devel openssl openssl-devel

网上源码安装

http://blog.csdn.net/dyllove98/article/details/8892509

the HTTP rewrite module requires the PCRE library

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

推荐文章
编辑推荐
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号