当前位置:首页 > 开发 > 移动开发 > 正文

Xcode6在10.9.4上面crash解决

发表于: 2015-11-13   作者:互联网   来源:转载   浏览:
摘要: 具体请看我的evernote 这里: 在10.9.4系统上面直接安装xcode6的beta3.和平时一样, 1.将beta3拖拽到application文件夹中。 2.等待copy完毕,执行xcode6,可是我得怎么都没有出现安装协议。郁闷啊。重来了好几次,依然都是这样。结果就造成每次启动xcode6都会crash,原因是会去 /System/Library/PrivateFrameworks

具体请看我的evernote 这里

在10.9.4系统上面直接安装xcode6的beta3.和平时一样,
1.将beta3拖拽到application文件夹中。
2.等待copy完毕,执行xcode6,可是我得怎么都没有出现安装协议。郁闷啊。重来了好几次,依然都是这样。结果就造成每次启动xcode6都会crash,原因是会去
/System/Library/PrivateFrameworks/PluginKit.framework这个库,可是这个库又要去引用/System/Library/Frameworks/CoreServices.Framewrok里面的_LSApplicationProxy的符号,能够CoreServices里面没有这个符号啊。看这个是不是因为plugin造成的呢。没有办法试试吧,如今~/Library/Developer/Xcode/UserData和插件文件夹~/Library/Application Support/Developer/Shared/Xcode/Plug-ins以及Xcode文件夹的PlugIns文件夹也删掉。结果,仅仅能还是郁闷结局啊。使用instruments的file activity检測了xcode5和其它人得xcode6都不会去载入PluginKit啊。
3.好吧,仅仅能试试讲PlugKit.framework重命名试试吧。然后重新启动xcode6,奇迹出现了,xcode6弹出提示让你安装一些组件来着。能做的就是install了。等待吧。安装完之后,奇迹真得降临了,成功了。能够swift了。不easy啊。

Xcode6在10.9.4上面crash解决

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号