当前位置:首页 > 开发 > 编程语言 > 编程 > 正文

Laravel版本更新异常4.2.8-> 4.2.9 Declaration of ... CompilerEngine ... should be compa

发表于: 2014-09-26   作者:bozch   来源:转载   浏览:
摘要: 昨天在为了把laravel升级到最新的版本,突然之间就出现了如下错误: ErrorException thrown with message "Declaration of Illuminate\View\Engines\CompilerEngine::handleViewException() should be compatible with Illuminate\View\Eng

昨天在为了把laravel升级到最新的版本,突然之间就出现了如下错误:

ErrorException thrown with message "Declaration of Illuminate\View\Engines\CompilerEngine::handleViewException() should be compatible with Illuminate\View\Engines\PhpEngine::handleViewException($e)"

发现这个错误的时候很蒙,不知道哪里出了错误,猜测了几种情况:

       1、更新的时候,有残留文件导致。 删除所有的更新文件,重新更新 - 》 发现木有问题;

       2、使用composer加载类的时候,加载过多导致的。 - > 可能性不大,经过排查无问题,毕竟是成熟的技术。

      3、(解决方案)细致排查 ,与compileEngine和PhpEngine相关的文件,-> 奇迹出现了,原来是在bootstrap里面有对ClassLoader等类 进行了重新定义。  删除之后 OK 成功运行。

 

 

     

Laravel版本更新异常4.2.8-> 4.2.9 Declaration of ... CompilerEngine ... should be compa

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号