当前位置:首页 > 开发 > 编程语言 > JDK JVM > 正文

[Adempiere]多JDK环境下的ad初始化问题

发表于: 2015-07-14   作者:dinguangx   来源:转载   浏览次数:
摘要: 机器环境:ubuntu ad版本:最新trunk(截止2015-3-17)   机器默认的JDK环境是1.6,而ad的最小环境限制为1.7,所以在执行RUN_build.sh时会报错。 由于工作环境限制,不能直接将JAVA_HOME修改为1.7,所以对RUN_build.sh做修改,增加: export JAVA_HOME=/home/dingguangxian/softwar

机器环境:ubuntu

ad版本:最新trunk(截止2015-3-17)

 

机器默认的JDK环境是1.6,而ad的最小环境限制为1.7,所以在执行RUN_build.sh时会报错。

由于工作环境限制,不能直接将JAVA_HOME修改为1.7,所以对RUN_build.sh做修改,增加:

export JAVA_HOME=/home/dingguangxian/software/jdk1.7.0_79
export CLASSPATH=$JAVA_HOME/lib/tools.jar

 

增加CLASSPATH环境变量的原因是RUN_build.sh脚本的ANT_CLASSPATH中有对$CLASSPATH的引用,而机器的环境变量引用的是1.6的CLASSPATH。

也可以直接删除ANT_CLASSPATH变量中对$CLASSPATH的引用,实测结果表明,删除对该变量的引用,并不影响脚本正常运行。

[Adempiere]多JDK环境下的ad初始化问题

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
1. 安装JDK 1.6. 2. 安装Eclipse IDE for Java EE Developers。 3. 导入adempire-360lts: 4. 关闭a
1. 用pgAdmin III创建用户adempiere/adempiere: 2. 创建adempiere360数据库: 3. 导入<ADEMPIER
配置jdk1.6环境变量 一、JDK1.6下载 目前JDK最新版本是JDK1.6,到http://java.sun.com/javase/downlo
原文链接:http://android.eoe.cn/topic/android_sdk 1. JDK 的下载 JDK有好几个类型版本,我们只需
1、Oracle官网下载JVM,我已经下载好了,JDK的版本为1.6文件jdk-6u11-dlj-linux-i586.bin。 2、利用
文章来源:http://www.itnose.net/detail/6035572.html 更多文章:http://www.itnose.net/type/10.h
一、准备工具: 1.JDK JDK 可以到官网下载 http://www.oracle.com/technetwork/java/javase/download
在整理中..... JDK 1.8安装 下载JDK1.8 jdk 1.8下载地址 点击JDK按钮 点击接受 因为我的window7系统
由于之前安装过JDK1.7 ,现在一个项目是JDK1.5的,那么需要更改了环境变量了,此处不再赘述如何设置
一、创建Dockerfile文件: 创建Dockerfile文件,下载jdk与tomcat放在Dockerfile同目录下。 Dockerfi
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号