当前位置:首页 > 开发 > 系统架构 > 架构 > 正文

Maven Integration for Eclipse

发表于: 2011-05-18   作者:dai_lm   来源:转载   浏览次数:
摘要: 原本以为安装这么个插件应该是兴手拈来,但是实际操作的时候却喷到一堆问题。通过不断的Google,终于顺利解决。 1. 添加依赖插件 ( 重要) Help -> Install New Software -> Available Software Sites -> Add 然后输入 Name: GEF Update Site: http://download.ecl
原本以为安装这么个插件应该是兴手拈来,但是实际操作的时候却喷到一堆问题。通过不断的Google,终于顺利解决。

1. 添加依赖插件 ( 重要
Help -> Install New Software -> Available Software Sites -> Add
然后输入
Name: GEF
Update Site: http://download.eclipse.org/tools/gef/updates/releases/

2. 安装Maven Integration for Eclipse
Update Site: http://m2eclipse.sonatype.org/sites/m2e

3. 安装Extra插件
Update Site: http://m2eclipse.sonatype.org/sites/m2e-extras

据说Eclipse 3.6.1以上只需要安装zest即可(zest可以在GEF中找到),未验证。


==========================================================

错误解决方法

1. JDK warning
在eclipse.ini中,添加-vm选项,指向JDK的安装路径。
如:
-vm
D:/Program Files/Java/jdk1.6.0_10/bin/javaw.exe

Maven Integration for Eclipse

  • 0

    开心

    开心

  • 0

    板砖

    板砖

  • 0

    感动

    感动

  • 0

    有用

    有用

  • 0

    疑问

    疑问

  • 0

    难过

    难过

  • 0

    无聊

    无聊

  • 0

    震惊

    震惊

编辑推荐
myeclipse6.5 安装maven后,启动报warning。。。。 解决方式: 添加 -vm D:\Program Files\Java\jdk1
若在Eclipse启动时,出现上图中的情况解决方法: 1:打开eclipse Click on ‘Window’ -> ‘Pref
源:http://cloudfoundry-doc.csdn.net/tools/STS/configuring-STS.html#installing-the-cloud-foun
Ant > Ant Eclipse IDE Integration Ant Eclipse IDE Integration To integrate Ant build file
1. 安装m2eclipse插件 要用Eclipse构建Maven项目,我们需要先安装meeclipse插件 点击eclipse菜单栏H
Maven实战(三)Eclipse构建Maven项目 博客分类: Maven实战 企业应用 1. 安装m2eclipse插件 要用Ec
问题描述: 使用Eclipse自带的Maven插件创建Web项目时报错: Could not resolve archetype org.apac
1. 安装m2eclipse插件 要用Eclipse构建Maven项目,我们需要先安装meeclipse插件 点击eclipse菜单栏H
1. 安装m2eclipse插件 要用Eclipse构建Maven项目,我们需要先安装meeclipse插件 点击eclipse菜单栏H
最近项目开发中需要使用maven。Maven这个东西是我2年前自学的。这2年之中基本没有使用过。现在项目
版权所有 IT知识库 CopyRight © 2009-2015 IT知识库 IT610.com , All Rights Reserved. 京ICP备09083238号